summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHsiu-Ming Chang2016-04-27 16:26:14 +0800
committerHsiu-Ming Chang2016-04-27 16:26:14 +0800
commitf8aa126ac07377eebe6c90f48a2b273e2a0b7437 (patch)
tree752b920e59948c359fbad8df3073d993a684b685
downloadaur-f8aa126ac07377eebe6c90f48a2b273e2a0b7437.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD38
-rw-r--r--hmtimer.install11
3 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f6370cd65de2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = hmtimer
+ pkgdesc = graphical shutdown timer
+ pkgver = 2.2
+ pkgrel = 1
+ url = https://sites.google.com/site/hsiumingstimer/
+ install = hmtimer.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = qt5-base
+ depends = qt5-multimedia
+ depends = hicolor-icon-theme
+ source = https://sourceforge.net/projects/hsiumingstimer/files/hmtimer-2.2/hmtimer-2.2-src.tar.bz2
+ md5sums = d868e56f7cebd8e9da90711cffda62ea
+
+pkgname = hmtimer
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5123fcd4108d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Hsiu-Ming Chang <cges30901 at gmail dot com>
+pkgname=hmtimer
+pkgver=2.2
+pkgrel=1
+pkgdesc="graphical shutdown timer"
+arch=('i686' 'x86_64')
+url="https://sites.google.com/site/hsiumingstimer/"
+license=('GPL3')
+groups=()
+depends=('qt5-base' 'qt5-multimedia' 'hicolor-icon-theme')
+makedepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install="$pkgname.install"
+changelog=
+source=("https://sourceforge.net/projects/hsiumingstimer/files/hmtimer-$pkgver/hmtimer-$pkgver-src.tar.bz2")
+noextract=()
+md5sums=('d868e56f7cebd8e9da90711cffda62ea')
+
+build() {
+ cd "$pkgname-$pkgver-src"
+ qmake
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver-src"
+
+ install -D -m0755 hmtimer/hmtimer $pkgdir/usr/bin/hmtimer
+ install -D -m0644 hmtimer/language/hmtimer_zh_TW.qm $pkgdir/usr/share/hmtimer/hmtimer_zh_TW.qm
+ install -D -m0644 hmtimer.desktop $pkgdir/usr/share/applications/hmtimer.desktop
+ install -D -m0644 hmtimer/hmtimer.png $pkgdir/usr/share/icons/hicolor/128x128/apps/hmtimer.png
+ install -D -m0644 hmtimer/hmtimer48.png $pkgdir/usr/share/icons/hicolor/48x48/apps/hmtimer.png
+}
diff --git a/hmtimer.install b/hmtimer.install
new file mode 100644
index 000000000000..1c0de2e4fa61
--- /dev/null
+++ b/hmtimer.install
@@ -0,0 +1,11 @@
+post_install() {
+ xdg-icon-resource forceupdate --theme hicolor &> /dev/null
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}