summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormyself6002022-10-04 16:30:01 +0200
committermyself6002022-10-04 16:30:01 +0200
commit92ba866eaa257eedb7dbf7ed508f517088b71b53 (patch)
tree2cf29497ea684feffa59fc1b2b874e05dbb02236
downloadaur-92ba866eaa257eedb7dbf7ed508f517088b71b53.tar.gz
Upload files
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD41
-rw-r--r--amazing.pngbin0 -> 95551 bytes
-rw-r--r--amazing32.pngbin0 -> 274 bytes
-rwxr-xr-xhode.desktop6
-rw-r--r--hode.ini44
-rw-r--r--hode.install3
-rw-r--r--hode.sh4
8 files changed, 125 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8edbaabf3e9b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = hode-git
+ pkgdesc = Heart of Darkness engine rewrite
+ pkgver = 26bcf11
+ pkgrel = 1
+ url = http://cyxdown.free.fr/hode/
+ install = hode.install
+ arch = x86_64
+ arch = aarch64
+ license = none
+ makedepends = make
+ makedepends = sdl2
+ makedepends = gcc
+ optdepends = heart-of-darkness: provides game data for hode engine
+ source = git+https://github.com/cyxx/hode.git
+ source = hode.ini
+ source = amazing.png
+ source = amazing32.png
+ source = hode.sh
+ source = hode.desktop
+ md5sums = SKIP
+ md5sums = 874bc298ab565d2d5141101781ef1082
+ md5sums = 6d414f0a121fc4bd36f37cb12b8d34d6
+ md5sums = bccc68e0d4e909f147a424dd8fc2e1dd
+ md5sums = dd04ae21e99c973deec654186543da3d
+ md5sums = bfdd04e5fdc88f9dfcc2664bbb7578d6
+
+pkgname = hode-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0f5d5ecb7bca
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+pkgname=hode-git
+pkgver=26bcf11
+pkgrel=1
+pkgdesc="Heart of Darkness engine rewrite"
+arch=(x86_64 aarch64)
+url=http://cyxdown.free.fr/hode/
+license=(none)
+makedepends=(make sdl2 gcc)
+optdepends=('heart-of-darkness: provides game data for hode engine')
+install=hode.install
+source=(
+ git+https://github.com/cyxx/hode.git
+ hode.ini
+ amazing.png
+ amazing32.png
+ hode.sh
+ hode.desktop)
+md5sums=(
+ SKIP
+ 874bc298ab565d2d5141101781ef1082
+ 6d414f0a121fc4bd36f37cb12b8d34d6
+ bccc68e0d4e909f147a424dd8fc2e1dd
+ dd04ae21e99c973deec654186543da3d
+ bfdd04e5fdc88f9dfcc2664bbb7578d6)
+pkgver(){
+ cd hode
+ git rev-parse --short HEAD
+}
+build(){
+ cd hode
+ make
+}
+package(){
+ cd hode
+ install hode ../hode.sh -Dt $pkgdir/usr/bin
+ install ../hode.ini -Dt $pkgdir/usr/share/hode
+ install ../amazing.png -Dt $pkgdir/usr/share/icons/hicolor/512x512/apps
+ install ../amazing32.png -D $pkgdir/usr/share/icons/hicolor/32x32/apps/amazing.png
+ install ../hode.desktop -Dt $pkgdir/usr/share/applications
+ install *.txt *.yaml -Dt $pkgdir/usr/share/doc/hode
+}
diff --git a/amazing.png b/amazing.png
new file mode 100644
index 000000000000..7f67b8bc0499
--- /dev/null
+++ b/amazing.png
Binary files differ
diff --git a/amazing32.png b/amazing32.png
new file mode 100644
index 000000000000..83879e9a74ba
--- /dev/null
+++ b/amazing32.png
Binary files differ
diff --git a/hode.desktop b/hode.desktop
new file mode 100755
index 000000000000..e123f4df1f76
--- /dev/null
+++ b/hode.desktop
@@ -0,0 +1,6 @@
+[Desktop Entry]
+Type=Application
+Name=Heart of Darkness (hode)
+Exec=sh hode.sh
+Icon=amazing
+Categories=Game
diff --git a/hode.ini b/hode.ini
new file mode 100644
index 000000000000..d49bb17f73cb
--- /dev/null
+++ b/hode.ini
@@ -0,0 +1,44 @@
+
+[engine]
+
+# disable animations playback
+disable_paf=false
+
+# disable monsters handling code
+disable_mst=false
+
+# disable sound handling code
+disable_sss=false
+
+# disable menu and start game directly
+disable_menu=false
+
+# maximum number of active sounds (original is 16)
+max_active_sounds=-1
+
+# default difficulty when bypassing menu (2:easy 1:normal 0:hard)
+difficulty=1
+
+# frame duration in milliseconds (original is 80ms, eg. 12.5hz)
+frame_duration=80
+
+# display splash screen when loading data files
+loading_screen=true
+
+
+[display]
+
+# scaling factor for game graphics (base resolution is 256x192)
+scale_factor=3
+
+# scaling algorithm for game graphics ('linear', 'nearest' or 'xbr')
+scale_algorithm=nearest
+
+# gamma correction
+gamma=1.0
+
+# fullscreen display
+fullscreen=true
+
+# widescreen (16:9)
+widescreen=true
diff --git a/hode.install b/hode.install
new file mode 100644
index 000000000000..9c1d224899ed
--- /dev/null
+++ b/hode.install
@@ -0,0 +1,3 @@
+post_install(){
+ [ -d /usr/share/heart-of-darkness ] || echo -e "\e[93mPlace your game data into ~/.hode folder\e[m"
+}
diff --git a/hode.sh b/hode.sh
new file mode 100644
index 000000000000..40e2667045d8
--- /dev/null
+++ b/hode.sh
@@ -0,0 +1,4 @@
+mkdir -p ~/.hode
+cp -u /usr/share/hode/hode.ini ~/.hode
+cd ~/.hode
+[ -d /usr/share/heart-of-darkness ] && hode --datapath=/usr/share/heart-of-darkness || hode