summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimone Pietro Rossi2015-06-19 14:04:21 +0200
committerSimone Pietro Rossi2015-06-19 14:04:21 +0200
commitd7eb8e4758b27c5dd201472fe1855b6aebe7a317 (patch)
tree0d6e989d6f000d409031f3bf4a7c7bbf2379cd89
downloadaur-d7eb8e4758b27c5dd201472fe1855b6aebe7a317.tar.gz
Primo commit.
-rw-r--r--.SRCINFO15
-rw-r--r--Makefile.diff41
-rw-r--r--PKGBUILD20
3 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eddb95531665
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = hodie
+ pkgdesc = Prints the date in Latin.
+ pkgver = 1.4
+ pkgrel = 1
+ url = http://hodie.sourceforge.net
+ arch = i686
+ arch = x86_64
+ license = custom
+ source = http://downloads.sourceforge.net/hodie/hodie-1.4.tar.gz
+ source = Makefile.diff
+ md5sums = fd3f23135fd74e17516aa0c08757edd9
+ md5sums = c65fae177943033f068cdeca16f7bd49
+
+pkgname = hodie
+
diff --git a/Makefile.diff b/Makefile.diff
new file mode 100644
index 000000000000..c7d9067b8794
--- /dev/null
+++ b/Makefile.diff
@@ -0,0 +1,41 @@
+--- Makefile 2008-08-03 15:20:34.000000000 +0530
++++ Makefile.1 2008-08-03 15:20:22.000000000 +0530
+@@ -3,20 +3,20 @@
+ CFLAGS=-g -Wall
+
+ # Install paths and command on recommendation from Peter Pentchev
+-INSTALL=/usr/bin/install -c
++INSTALL=/bin/install -c
+
+ # Some prefer /usr/local over /usr as installation root
+ #INSTALL_PATH=/usr/local
+-INSTALL_PATH=/usr
++INSTALL_PATH=$(DESTDIR)/usr
+
+ BINDIR=$(INSTALL_PATH)/bin
+-MAN1DIR=$(INSTALL_PATH)/man/man1
++MAN1DIR=$(INSTALL_PATH)/share/man/man1
+
+ # BSD might prefer this
+ # DOCPATH=$(INSTALL_PATH)/share/doc/hodie
+
+ # Linux might prefer this:
+-DOCDIR=$(INSTALL_PATH)/doc/packages/hodie
++DOCDIR=$(INSTALL_PATH)/share/doc/hodie
+
+ #############################
+ # End of user configuration #
+@@ -41,10 +41,10 @@
+ $(OBJECTS): $(HEADERS)
+
+ install: $(EXEC)
+- $(INSTALL) -s -m 755 $(EXEC) $(BINDIR)
+- install -m 644 hodie.1 $(MAN1DIR)
++ $(INSTALL) -D -m755 $(EXEC) $(BINDIR)/$(EXEC)
++ install -D -m644 hodie.1 $(MAN1DIR)/hodie.1
+ install -d $(DOCDIR)
+- install -m 644 $(DOCS) $(DOCDIR)
++ install -m644 $(DOCS) $(DOCDIR)
+
+ uninstall:
+ -rm -f $(BINDIR)/$(EXEC)
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dbee0a92f793
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# $Id:$
+# Maintainer: Abhishek Dasgupta <abhidg@gmail.com>
+pkgname=hodie
+pkgver=1.4
+pkgrel=1
+pkgdesc="Prints the date in Latin."
+url="http://hodie.sourceforge.net"
+arch=(i686 x86_64)
+license=('custom')
+source=(http://downloads.sourceforge.net/hodie/$pkgname-$pkgver.tar.gz
+ Makefile.diff)
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ patch -p0 -i ../Makefile.diff || return 1
+ make || return 1
+ make DESTDIR="$pkgdir" install
+}
+md5sums=('fd3f23135fd74e17516aa0c08757edd9'
+ 'c65fae177943033f068cdeca16f7bd49')