summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJulien Freyermuth2017-06-13 11:34:34 +0200
committerJulien Freyermuth2017-06-13 11:34:34 +0200
commit38706b1390632ad5a5432f993b03c1e8385ae299 (patch)
tree709ac658493b5569bb43bd227794943046c55abb
downloadaur-38706b1390632ad5a5432f993b03c1e8385ae299.tar.gz
First commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD37
-rw-r--r--hogc-0.0.1.tar.gzbin0 -> 3072 bytes
-rw-r--r--hogc.install21
4 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f97071bdd72d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Tue Jun 13 09:34:14 UTC 2017
+pkgbase = hogc
+ pkgdesc = human detection in C++ and opencv
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://github.com/Chipsterjulien/hogc
+ install = hogc.install
+ arch = any
+ license = WTFPL
+ makedepends = opencv cmake
+ options = !strip
+ source = hogc-0.0.1.tar.gz
+ sha512sums = ad03a26c0a228ee054d4b0cfe512e5950a8e55eceb096eeb7d8b89411b5b81d82415616a0977f156a465d3de9e9960d1f5191fc7751b9952116af3276f9b35b1
+
+pkgname = hogc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e93ff6456a57
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+#Maintainer: Chipster Julien <julien dot chipster @ archlinux dot fr>
+
+pkgname=hogc
+pkgver=0.0.1
+pkgrel=1
+pkgdesc="human detection in C++ and opencv"
+arch=('any')
+url="https://github.com/Chipsterjulien/hogc"
+license=('WTFPL')
+makedepends=('opencv cmake')
+options=('!strip')
+source=("$pkgname-$pkgver.tar.gz")
+install=hogc.install
+
+_builddir="$pkgname-$pkgver"
+
+build() {
+ cd "$_builddir"
+ # run cmake .
+ cmake . || return 1
+ # run make
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+
+ # hogc_sample.ini
+ install -Dm644 cfg/"$pkgname"_sample.ini \
+ "$pkgdir"/etc/$pkgname/"$pkgname"_sample.ini || return 1
+
+ # hogc binary
+ install -m755 -o root -g root -D "$srcdir"/$pkgname-$pkgver/$pkgname \
+ "$pkgdir"/usr/bin/$pkgname || return 1
+}
+
+sha512sums=('ad03a26c0a228ee054d4b0cfe512e5950a8e55eceb096eeb7d8b89411b5b81d82415616a0977f156a465d3de9e9960d1f5191fc7751b9952116af3276f9b35b1')
diff --git a/hogc-0.0.1.tar.gz b/hogc-0.0.1.tar.gz
new file mode 100644
index 000000000000..184ebe1d029e
--- /dev/null
+++ b/hogc-0.0.1.tar.gz
Binary files differ
diff --git a/hogc.install b/hogc.install
new file mode 100644
index 000000000000..d322c6d2d627
--- /dev/null
+++ b/hogc.install
@@ -0,0 +1,21 @@
+post_install() {
+ pkgname=hogc
+
+ # Fixing membership
+ chown -R julien: /etc/$pkgname
+
+ true
+}
+
+post_upgrade() {
+ pkgname=hogc
+
+ chown -R julien: /etc/$pkgname
+
+ true
+}
+
+pre_remove() {
+
+ true
+}