summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwangjiezhe2015-07-21 16:34:47 +0800
committerwangjiezhe2015-07-21 16:34:47 +0800
commit22d37020b69af179f70ab858498b81c7c120c564 (patch)
tree49eb8db9912e925846b23ca31506da7ac55133bc
downloadaur-22d37020b69af179f70ab858498b81c7c120c564.tar.gz
Initial import
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD32
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..092ee08a3048
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = hoichess
+ pkgdesc = Xboard compatible chess engine and xiangqi (Chinese chess) engine
+ pkgver = 0.16.0
+ pkgrel = 1
+ url = http://www.hoicher.de/hoichess
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ source = http://www.hoicher.de/hoichess/download/hoichess-0.16.0-gpl.tar.gz
+ md5sums = 0bea20843c30410de1f865b6efb15b85
+
+pkgname = hoichess
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8712498c2676
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Daniel Renninghoff <renninghoff AT archlinux DOT info>
+# Contributor: gucong <gucong43216@gmail.com>
+# Contributor: P. A. López-Valencia <palopezv AT gmail DOT com>
+# Contributor: wangjiezhe <wangjiezhe AT yandex DOT com>
+
+pkgname=hoichess
+pkgver=0.16.0
+pkgrel=1
+pkgdesc="Xboard compatible chess engine and xiangqi (Chinese chess) engine"
+arch=('i686' 'x86_64')
+license=('GPL2')
+url="http://www.hoicher.de/hoichess"
+depends=()
+source=(${url}/download/${pkgname}-${pkgver}-gpl.tar.gz)
+md5sums=('0bea20843c30410de1f865b6efb15b85')
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+ sed -i 's/games$/bin/' Makefile
+ sed -i 's/CXXFLAGS\ =/CXXFLAGS\ +=/' src/Makefile
+ sh "book/download-gnuchess-book"
+}
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+}