summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormutantmonkey2013-08-18 14:02:57 -0700
committermutantmonkey2013-08-18 14:02:57 -0700
commit63a8be48f41797d7a4451560a8ccbbdbc51596de (patch)
tree17a137eb5660aece12984937f095f9d67d24e0c2
downloadaur-63a8be48f41797d7a4451560a8ccbbdbc51596de.tar.gz
add hokiestalker-git
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD27
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0734d4355d63
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = hokiestalker-git
+ pkgdesc = Query the Virginia Tech people search service for information about a person.
+ pkgver = 28.02f5f8f
+ pkgrel = 1
+ url = https://github.com/mutantmonkey/hokiestalker
+ arch = any
+ license = ISC
+ makedepends = git
+ depends = python
+ depends = python-lxml
+ provides = hokiestalker
+ conflicts = hokiestalker
+ source = git+https://github.com/mutantmonkey/hokiestalker.git
+ sha256sums = SKIP
+
+pkgname = hokiestalker-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7e3718d62fcc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: mutantmonkey <aur@mutantmonkey.in>
+pkgname=hokiestalker-git
+_gitname=hokiestalker
+pkgver=28.02f5f8f
+pkgrel=1
+pkgdesc="Query the Virginia Tech people search service for information about a person."
+url="https://github.com/mutantmonkey/hokiestalker"
+arch=('any')
+license=('ISC')
+depends=('python' 'python-lxml')
+makedepends=('git')
+provides=('hokiestalker')
+conflicts=('hokiestalker')
+source=('git+https://github.com/mutantmonkey/hokiestalker.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $_gitname
+ echo $(git rev-list --count master).$(git rev-parse --short master)
+}
+
+package() {
+ cd $_gitname
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: