summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthijs Tadema2020-03-12 12:24:58 +0100
committerMatthijs Tadema2020-03-12 12:24:58 +0100
commit546772935119a87f8f3a5ae20d059875ec2fcfad (patch)
tree4741a1dd7dafcd5279d9bbbcd961369407fe6f88
downloadaur-546772935119a87f8f3a5ae20d059875ec2fcfad.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD43
-rw-r--r--hole2.patch30
3 files changed, 91 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b542e3c7a0d0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = hole2-git
+ pkgdesc = Analyzes the pore dimensions of ion channels
+ pkgver = v2.004pre.r24.ba82cfc
+ pkgrel = 1
+ url = https://github.com/osmart/hole2
+ arch = x86_64
+ license = Apache
+ makedepends = git
+ depends = gcc-libs
+ provides = hole2
+ conflicts = hole2
+ source = git+https://github.com/osmart/hole2.git
+ source = hole2.patch
+ md5sums = SKIP
+ md5sums = 6443d83cc884f733094dddba7b279314
+
+pkgname = hole2-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eab0c435ba6b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Matthijs Tadema <M dot J dot Tadema at pm dot me>
+pkgname=hole2-git
+pkgver=v2.004pre.r24.ba82cfc
+pkgrel=1
+pkgdesc="Analyzes the pore dimensions of ion channels"
+arch=('x86_64')
+url='https://github.com/osmart/hole2'
+license=('Apache')
+depends=('gcc-libs')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=('git+https://github.com/osmart/hole2.git'
+ "${pkgname%-git}.patch")
+md5sums=('SKIP'
+ '6443d83cc884f733094dddba7b279314')
+# Compiling didn't work for me on multiple processors
+MAKEFLAGS=${MAKEFLAGS/-j[0-9]*/-j1}
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ # Git, tags available
+ printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+prepare() {
+ cd "$srcdir/${pkgname%-git}"
+ patch -p1 -i "$srcdir/${pkgname%-git}.patch"
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}/src"
+ make
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ bash tarball.sh
+ mkdir -p $pkgdir/usr/
+ cd $pkgdir/usr/
+ tar -xf ${srcdir}/${pkgname%-git}/"${pkgname%-git}-`uname`-`uname -m`.tar.gz"
+ rm ${srcdir}/${pkgname%-git}/"${pkgname%-git}-`uname`-`uname -m`.tar.gz"
+}
diff --git a/hole2.patch b/hole2.patch
new file mode 100644
index 000000000000..11e22b6cfd6f
--- /dev/null
+++ b/hole2.patch
@@ -0,0 +1,30 @@
+diff --git a/src/Makefile b/src/Makefile
+index 7f8e5ce..604baeb 100644
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -14,9 +14,9 @@ FFLAGS = -fd-lines-as-comments -fbackslash -std=legacy
+ # for linux we need -static, OSX does not
+ UNAME := $(shell uname)
+ # linux needs -static but OSX needs -static-libgfortran
+-ifeq ($(UNAME), Linux)
+- FFLAGS += -static
+-endif
++#ifeq ($(UNAME), Linux)
++# FFLAGS += -static
++#endif
+ ifeq ($(UNAME), Darwin)
+ FFLAGS += -static-libgfortran
+ endif
+diff --git a/tarball.sh b/tarball.sh
+index c1a087b..d6649ab 100755
+--- a/tarball.sh
++++ b/tarball.sh
+@@ -2,8 +2,6 @@
+ # command used to packup distribution tar ball
+ UNAME=`uname`-`uname -m` # for instance Linux-x86_64
+ FNAME=hole2/hole2
+-FNAME+=-$HoleBuild # for instance NotForProfit
+-FNAME+=-$HoleVersion # for instance 2.004
+ FNAME+=-$UNAME # for instance Linux-x86_64
+ FNAME+=.tar.gz
+ echo "tarball name $FNAME"