summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Majewsky2015-12-04 22:37:03 +0100
committerStefan Majewsky2015-12-04 22:37:20 +0100
commit4944e8e45a7b356d240f3414a3ddc3da528f4f24 (patch)
tree755f35ad33feb8c7c604476397ee31b0c873909e
parentc860ee6e5d87d9866a210bca940d5f6c8920a367 (diff)
downloadaur-4944e8e45a7b356d240f3414a3ddc3da528f4f24.tar.gz
v1.0-beta.2-3
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD30
2 files changed, 27 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index df4ef6811826..b494d65acb4d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,19 @@
pkgbase = holo
pkgdesc = Minimalistic configuration management
- pkgver = 0.9.0
- pkgrel = 1
+ pkgver = 1.0beta.2
+ pkgrel = 3
url = http://holocm.org
+ arch = i686
arch = x86_64
- license = GPL2
+ license = GPL3
makedepends = go
makedepends = perl
- depends = shadow
- source = https://github.com/holocm/holo/releases/download/v0.9.0/holo-0.9.0.tar.gz
- md5sums = b14333d0c83a58938a6c1b2b45db55ee
+ depends = git
+ provides = holo-files=1.0beta.2
+ provides = HOLO_API_VERSION=1
+ backup = etc/holorc
+ source = https://github.com/holocm/holo/archive/v1.0-beta.2.tar.gz
+ md5sums = c4e35e16a5069f05ac9144545bb196bf
pkgname = holo
diff --git a/PKGBUILD b/PKGBUILD
index 3deafceee524..c2d85e24be08 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,36 @@
-# This PKGBUILD is maintained at: https://github.com/majewsky/system-configuration/tree/master/holo
pkgname='holo'
-pkgver=0.9.0
-pkgrel=2
+_actual_pkgver=1.0-beta.2
+pkgver=${_actual_pkgver//-/}
+pkgrel=3
pkgdesc='Minimalistic configuration management'
arch=('i686' 'x86_64')
url='http://holocm.org'
-license=('GPL2')
+license=('GPL3')
depends=(
- # 'git' # TODO: uncomment this for 0.10 release where holo uses git-diff for file diffs
- 'fakeroot' # required for holo-build
- 'pacman' # required for holo-build pacman generator (and pulls in other required tools, e.g. bsdtar and xz)
- 'shadow' # required for holo users/groups provisioning
+ 'git' # holo-files uses git-diff for file diffs
)
makedepends=('go' 'perl')
-source=("https://github.com/holocm/holo/releases/download/v${pkgver}/holo-${pkgver}.tar.gz")
-md5sums=('b14333d0c83a58938a6c1b2b45db55ee')
+provides=(
+ "holo-files=${pkgver}" # required for holo-build packages that have a holo-files dependency when there are files below /usr/share/holo/files
+ 'HOLO_API_VERSION=1'
+)
+backup=(
+ 'etc/holorc'
+)
+source=("https://github.com/holocm/${pkgname}/archive/v${_actual_pkgver}.tar.gz")
+md5sums=('c4e35e16a5069f05ac9144545bb196bf')
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "${srcdir}/${pkgname}-${_actual_pkgver}"
make
}
check() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "${srcdir}/${pkgname}-${_actual_pkgver}"
make check
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "${srcdir}/${pkgname}-${_actual_pkgver}"
make install DESTDIR="${pkgdir}"
}