summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex2021-10-01 21:28:36 +1300
committerAlex2021-10-01 21:28:36 +1300
commitb25b3add8deea9205879520ba7d47a07b035ada7 (patch)
treea73b2d304ee2c0a76f7018e54d501d62425d5d6a
downloadaur-b25b3add8deea9205879520ba7d47a07b035ada7.tar.gz
initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD28
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6c6b5d0a4a46
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = holochain-launcher
+ pkgdesc = A cross-platform executable that launches a local Holochain conductor, and installs and opens apps
+ pkgver = 0.2.2
+ pkgrel = 1
+ url = https://github.com/holochain/launcher/releases
+ arch = x86_64
+ license = custom:CAL
+ depends = libappindicator-gtk3
+ noextract = holochain-launcher_0.2.2_amd64.deb
+ source = https://github.com/holochain/launcher/releases/download/v0.2.2/holochain-launcher_0.2.2_amd64.deb
+ sha256sums = d59d09cad56f493edfc3fcc09a744f8a36f804a13873555f27055e7d9026ec04
+
+pkgname = holochain-launcher
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..69e06869a1f6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: robot5x <alex at robot5x dot com>
+
+pkgname=holochain-launcher
+pkgver=0.2.2
+pkgrel=1
+pkgdesc="A cross-platform executable that launches a local Holochain conductor, and installs and opens apps"
+arch=('x86_64')
+url="https://github.com/holochain/launcher/releases"
+license=(custom:CAL)
+depends=(libappindicator-gtk3)
+optdepends=()
+conflicts=()
+replaces=()
+source=("https://github.com/holochain/launcher/releases/download/v${pkgver}/${pkgname}_${pkgver}_amd64.deb")
+noextract=("${pkgname}_${pkgver}_amd64.deb")
+sha256sums=('d59d09cad56f493edfc3fcc09a744f8a36f804a13873555f27055e7d9026ec04')
+package() {
+ bsdtar -O -xf "${pkgname}_${pkgver}_amd64.deb" data.tar.gz | bsdtar -C "${pkgdir}" -xJf -
+
+ chown root:root -R ../pkg/holochain-launcher/usr/bin
+ chmod 755 -R ../pkg/holochain-launcher/usr/bin
+ chown root:root -R ../pkg/holochain-launcher/usr/lib
+ chmod 755 -R ../pkg/holochain-launcher/usr/lib
+ chown root:root -R ../pkg/holochain-launcher/usr/share
+ chmod 755 -R ../pkg/holochain-launcher/usr/share
+ # Permissions fix
+ find "${pkgdir}" -type d -exec chmod 755 {} \;
+}