aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEthan Skinner2018-03-18 11:49:02 -0500
committerEthan Skinner2018-03-18 12:10:09 -0500
commit2ca78b3f0a1b5347b90c77915d55c4eb4867a137 (patch)
treebc98c81db1a10d98fae987e796cbed53e28e0dd8
parent710d1f322b68821710110a8f3a994478a44ed04c (diff)
downloadaur-2ca78b3f0a1b5347b90c77915d55c4eb4867a137.tar.gz
Add warning about recorder history limit change
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD4
-rw-r--r--hass.install18
3 files changed, 22 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a7c2c6a0f0e2..9fc4d2bf1184 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = home-assistant
pkgdesc = Open-source home automation platform running on Python 3
pkgver = 0.65.5
- pkgrel = 1
+ pkgrel = 2
url = https://home-assistant.io/
install = hass.install
arch = any
@@ -25,6 +25,7 @@ pkgbase = home-assistant
depends = python-astral
depends = python-certifi
depends = python-attrs
+ depends = python-async-timeout
optdepends = git: install component requirements from github
optdepends = net-tools: necessary for nmap discovery
replaces = python-home-assistant
@@ -37,7 +38,7 @@ pkgbase = home-assistant
sha512sums = fe96bd3df3ba666fd9f127c466d1dd1dd7314db2e57826a2b319c8a0bfad7aedeac398e748f93c6ecd9c2247ebbae196b8b0e7263b8681e2b7aeab6a8bfeab80
sha512sums = 100665ac35370c3ccec65d73521568de21cebf9e46af364124778861c94e338e32ad9abb675d3917f97d351dd7867e3ab2e80c26616330ae7cf0d9dc3f13369b
sha512sums = 8babcf544c97ec5ad785014f0b0d5dca556a2f5157dadcbe83d49d4669b74f6349e274810ec9a028fcec208c6c8fbbe6b3899d2933b56163b9e506570879a3ad
- sha512sums = e73e363b5eea1a5b2fdb2ba91c17672356b9accd14ecae66ee713be889abe9bbe6a4d2f55d106f4dc9430246326ace4eb29642e9fed1048462b10c42db14a826
+ sha512sums = 65edbf1e544322deb6b5b8e1197e54c5cb8b25e3dad7b4b882ca4d41d3240b3f049c2e928f083e261d14aa5e54ca0b228f128796a07f151cd01cc867acfdb305
pkgname = home-assistant
diff --git a/PKGBUILD b/PKGBUILD
index 4336bcc157bf..d675b1aed9eb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname="home-assistant"
pkgdesc='Open-source home automation platform running on Python 3'
pkgver=0.65.5
-pkgrel=1
+pkgrel=2
url="https://home-assistant.io/"
license=('APACHE')
arch=('any')
@@ -29,7 +29,7 @@ sha512sums=('8b34d9e39aec7b0be8247659faada3ee305f6686d1a8a5d2a431646c1fdef60f767
'fe96bd3df3ba666fd9f127c466d1dd1dd7314db2e57826a2b319c8a0bfad7aedeac398e748f93c6ecd9c2247ebbae196b8b0e7263b8681e2b7aeab6a8bfeab80'
'100665ac35370c3ccec65d73521568de21cebf9e46af364124778861c94e338e32ad9abb675d3917f97d351dd7867e3ab2e80c26616330ae7cf0d9dc3f13369b'
'8babcf544c97ec5ad785014f0b0d5dca556a2f5157dadcbe83d49d4669b74f6349e274810ec9a028fcec208c6c8fbbe6b3899d2933b56163b9e506570879a3ad'
- 'e73e363b5eea1a5b2fdb2ba91c17672356b9accd14ecae66ee713be889abe9bbe6a4d2f55d106f4dc9430246326ace4eb29642e9fed1048462b10c42db14a826')
+ '65edbf1e544322deb6b5b8e1197e54c5cb8b25e3dad7b4b882ca4d41d3240b3f049c2e928f083e261d14aa5e54ca0b228f128796a07f151cd01cc867acfdb305')
#validpgpkeys=('') # TODO https://github.com/home-assistant/home-assistant/issues/9487
install='hass.install'
diff --git a/hass.install b/hass.install
index 8bc1f253369f..de6381dad008 100644
--- a/hass.install
+++ b/hass.install
@@ -1,3 +1,19 @@
post_remove() {
- echo "Home Assistant data directory '/var/lib/hass' is left untouched. Remove it if you are really sure you won't need your data in the future."
+ echo "Home Assistant data directory '/var/lib/hass' is left untouched. Remove it if you are really sure you won't need your data in the future."
+}
+
+post_upgrade() {
+ if [ "$(vercmp $2 '0.65.5-2')" -lt 0 ]; then
+ echo ""
+ echo "Notice: Home Assistant now defaults to purge recorded history that is older than 10 days. If you want to keep your recorded data for longer than that, you must configure the number of days to retain before starting 0.64+ for the first time, for example:"
+ echo ""
+ echo "recorder:"
+ echo " purge_keep_days: 30"
+ echo ""
+ echo "If you want to keep the previous default of never deleting history, use this configuration:"
+ echo ""
+ echo "recorder:"
+ echo " purge_interval: 0"
+ echo ""
+ fi
}