summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorge Rawlinson2023-10-15 21:24:43 +1300
committerGeorge Rawlinson2023-10-15 21:24:43 +1300
commite99d34b2a1c789c38bad30d9f1251104f7411390 (patch)
treee1d4ee37e18221682d7eef62b324bbfd8b73b957
parent578c85a31aee8472ddb817ad0c2de2ddf9f33088 (diff)
downloadaur-e99d34b2a1c789c38bad30d9f1251104f7411390.tar.gz
upgpkg: home-assistant-hacs 1.33.0-1
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD50
2 files changed, 26 insertions, 42 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f412073177e7..8bfe6434c3e6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = home-assistant-hacs
- pkgdesc = HACS gives you a powerful UI to handle downloads of all your custom needs
- pkgver = 1.28.4
+ pkgdesc = Home Assistant Community Store
+ pkgver = 1.33.0
pkgrel = 1
- url = https://hacs.xyz/
+ url = https://hacs.xyz
arch = any
- license = AGPL
- makedepends = unzip
- depends = python-aiofiles
- noextract = hacs.zip
- source = hacs.zip::https://github.com/hacs/integration/releases/download/1.28.4/hacs.zip
- sha256sums = 0cfc5e07ab5c24373ff098504592802ba5979005f7f428f7bc99bef863adf9ff
+ license = MIT
+ depends = home-assistant
+ noextract = home-assistant-hacs-1.33.0.zip
+ source = home-assistant-hacs-1.33.0.zip::https://github.com/hacs/integration/releases/download/1.33.0/hacs.zip
+ sha512sums = 0e542a125e2340492b9792ba501e2c500fd3524d59b63e5c714b3f362a9c90871969452b3f15359d77cbf7a75d7e216986b301b740203dddde47e373303982e0
+ b2sums = fbd5040b4771d183cd46e382c1bf9fb3a7846cb828d7736e2cd0495107f4551f3aed38a445e6b7696f4cef6dec926f682e5fbdb9ca82de54ae3ffe86182c2d8d
pkgname = home-assistant-hacs
diff --git a/PKGBUILD b/PKGBUILD
index e6a9a267695e..035c65edfc8b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,24 @@
-# Maintainer: Ewout van Mansom <ewout@vanmansom.name>
+# Maintainer: George Rawlinson <grawlinson@archlinux.org>
pkgname=home-assistant-hacs
-pkgdesc='Customize Home Assistant by downloading different integrations and themes'
-pkgver=1.28.4
+pkgver=1.33.0
pkgrel=1
-arch=(any)
-url='https://hacs.xyz/'
-license=(AGPL)
-depends=(
- python-aiofiles
-)
-makedepends=(
- unzip
-)
-_tag=1.28.4
-noextract=(
- 'hacs.zip'
-)
-source=(
- "hacs.zip::https://github.com/hacs/integration/releases/download/${_tag}/hacs.zip"
-)
-sha256sums=('0cfc5e07ab5c24373ff098504592802ba5979005f7f428f7bc99bef863adf9ff')
+pkgdesc='Home Assistant Community Store'
+arch=('any')
+url='https://hacs.xyz'
+license=('MIT')
+depends=('home-assistant')
+noextract=("$pkgname-$pkgver.zip")
+source=("$pkgname-$pkgver.zip::https://github.com/hacs/integration/releases/download/$pkgver/hacs.zip")
+sha512sums=('0e542a125e2340492b9792ba501e2c500fd3524d59b63e5c714b3f362a9c90871969452b3f15359d77cbf7a75d7e216986b301b740203dddde47e373303982e0')
+b2sums=('fbd5040b4771d183cd46e382c1bf9fb3a7846cb828d7736e2cd0495107f4551f3aed38a445e6b7696f4cef6dec926f682e5fbdb9ca82de54ae3ffe86182c2d8d')
-prepare() {
- cd "$srcdir"
-
- unzip -o hacs.zip -d "$pkgname-$pkgver"
-}
-
-_hapath="/var/lib/private/hass/"
package() {
- cd "$pkgname-$pkgver"
+ local hacs_path="$pkgdir/var/lib/private/hass/custom_components/hacs"
- install -dm700 "$pkgdir/var/lib/private"
- install -dm755 "$pkgdir/$_hapath/custom_components"
- cp -dr --preserve=mode,timestamp . "$pkgdir/$_hapath/custom_components/hacs"
-}
+ # ensure private has 0700 perms
+ install -vdm700 "$pkgdir/var/lib/private"
+ install -vd "$hacs_path"
-# vim: ts=2 sw=2 ft=PKGBUILD et:
+ bsdtar --extract --file "$pkgname-$pkgver.zip" --directory "$hacs_path"
+}