summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorge Rawlinson2021-05-19 01:49:12 +0000
committerGeorge Rawlinson2021-05-19 01:51:29 +0000
commitd654499edea20c9b6fb7d7a2bd96ae9a8b625a5e (patch)
treed9a80ba702184debaa35d5dabbcf4b69450e7d26
parentf9f787add7304ebf8451932800dc3d2af97ac250 (diff)
downloadaur-d654499edea20c9b6fb7d7a2bd96ae9a8b625a5e.tar.gz
upgpkg: homebridge 1.3.4-2
* Added note about why build process differs from standard Node.js guidelines. * Added docstring to optdepends. * Removed unnecessary dependencies: * git * python * node-gyp * avahi
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD31
2 files changed, 11 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 87de363f36c5..973b0049efcb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,13 @@
pkgbase = homebridge
pkgdesc = HomeKit support for the impatient
pkgver = 1.3.4
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/homebridge/homebridge
arch = any
license = Apache
- makedepends = git
makedepends = npm
- makedepends = python
- makedepends = node-gyp
depends = nodejs
- depends = avahi
- optdepends = homebridge-config-ui-x
+ optdepends = homebridge-config-ui-x: for web-based management tool
options = !emptydirs
options = !strip
source = homebridge-1.3.4.tar.gz::https://github.com/homebridge/homebridge/archive/v1.3.4.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 61e948bcb41f..84b7f722005f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,30 +2,24 @@
pkgname=homebridge
pkgver=1.3.4
-pkgrel=1
+pkgrel=2
pkgdesc="HomeKit support for the impatient"
arch=('any')
url="https://github.com/homebridge/homebridge"
license=('Apache')
-depends=(
- 'nodejs'
- 'avahi'
-)
-makedepends=(
- 'git'
- 'npm'
- 'python'
- 'node-gyp'
-)
-optdepends=(
- 'homebridge-config-ui-x'
-)
+depends=('nodejs')
+makedepends=('npm')
+optdepends=('homebridge-config-ui-x: for web-based management tool')
options=('!emptydirs' '!strip')
source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
b2sums=('91a3cf0e1b174f2122d23a13e3c3b45843f8ce6391f1b9684ffc0d5044e51e8412f85625bbe1aaec4f9fbd4ddc0958091a3310e5d3e4ccfe2e406b3a7fe36e41')
build() {
cd "$pkgname-$pkgver"
+
+ # NOTE: package is built this way because the dist/ directory is not
+ # included in the source, only in npm source due to a prepublish script
+ # which does not get installed correctly if the npm source is used.
# install dependencies
npm install
@@ -39,16 +33,9 @@ build() {
package() {
cd "$pkgname-$pkgver"
- npm install --global --prefix "$pkgdir/usr" "$srcdir/$pkgname-$pkgver/$pkgname-$pkgver.tgz"
-
- # Non-deterministic race in npm gives 777 permissions to random directories.
- # See https://github.com/npm/cli/issues/1103 for details.
- find "$pkgdir/usr" -type d -exec chmod 755 {} +
+ npm install --global --prefix "$pkgdir/usr" "$pkgname-$pkgver.tgz"
# npm gives ownership of ALL FILES to build user
# https://bugs.archlinux.org/task/63396
chown -R root:root "$pkgdir"
-
- # license
- install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname" "$pkgdir/usr/lib/node_modules/$pkgname/LICENSE"
}