summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGoliathLabs2020-04-24 22:00:35 +0200
committerGoliathLabs2020-04-24 22:00:35 +0200
commitede2f74eda4214db394d296dc9838ac8d547a539 (patch)
tree895e4a757453eec8dbae6d25049655d5fdd7364f
parentde212e12e968f9a3eaa7eaa28d9cb9b2a2ae1460 (diff)
downloadaur-ede2f74eda4214db394d296dc9838ac8d547a539.tar.gz
Updated: Dependency
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD14
-rw-r--r--homebridge.install24
3 files changed, 24 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 91414a98c527..9840d9cb910e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = homebridge-git
pkgdesc = HomeKit support for the impatient
- pkgver = 0.4.46.r16.g84b4733
+ pkgver = 0.4.53.r9.g8a2a122
pkgrel = 1
url = https://github.com/nfarina/homebridge
install = homebridge.install
@@ -8,7 +8,7 @@ pkgbase = homebridge-git
license = apache
makedepends = git
makedepends = npm
- makedepends = python2
+ makedepends = python
depends = nodejs>=4.3.2
depends = avahi
provides = homebridge
@@ -18,10 +18,10 @@ pkgbase = homebridge-git
source = homebridge-system.service
source = homebridge-user.service
source = homebridge.install
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
+ sha512sums = SKIP
+ sha512sums = 56eb3b04e0a84753b98cfd91a2f3b96d33e20639e3b38faa1c0388fcf55025ea8776efee6723b61b2ad8bc55689708f2fce5f6387eb3e23429b9feac44e521d1
+ sha512sums = b9ea4a2597b54eb3bfa427d48bb5bb807c4b629bd07c73501a3778fcc8ddbc4cba3f1557f55fc76d40d5085cf73e54b11cc631d1962814641a17242487440468
+ sha512sums = de43f228bdfbf88ec92adaa46a32c772c6bb1f265899d56c4e9a70b2e9bd3381f45be0345b1bd55e8ec2f3b61fa1f903d823162293464b3e1b43aab8b772b6dd
pkgname = homebridge-git
diff --git a/PKGBUILD b/PKGBUILD
index e4e758d31cb4..c134c0d029b7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=homebridge-git
_gitname=homebridge
-pkgver=0.4.46.r16.g84b4733
+pkgver=0.4.53.r9.g8a2a122
pkgrel=1
pkgdesc="HomeKit support for the impatient"
arch=('any')
@@ -12,7 +12,7 @@ depends=('nodejs>=4.3.2' 'avahi')
makedepends=(
'git'
'npm'
- 'python2' # Needed for node-gyp for building native modules
+ 'python' # Needed for node-gyp for building native modules
)
provides=('homebridge')
conflicts=('homebridge')
@@ -23,12 +23,10 @@ source=(
"${_gitname}-user.service"
"${_gitname}.install"
)
-sha256sums=(
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
-)
+sha512sums=('SKIP'
+ '56eb3b04e0a84753b98cfd91a2f3b96d33e20639e3b38faa1c0388fcf55025ea8776efee6723b61b2ad8bc55689708f2fce5f6387eb3e23429b9feac44e521d1'
+ 'b9ea4a2597b54eb3bfa427d48bb5bb807c4b629bd07c73501a3778fcc8ddbc4cba3f1557f55fc76d40d5085cf73e54b11cc631d1962814641a17242487440468'
+ 'de43f228bdfbf88ec92adaa46a32c772c6bb1f265899d56c4e9a70b2e9bd3381f45be0345b1bd55e8ec2f3b61fa1f903d823162293464b3e1b43aab8b772b6dd')
install="${_gitname}.install"
diff --git a/homebridge.install b/homebridge.install
index e2787d7787b1..77f8cac04588 100644
--- a/homebridge.install
+++ b/homebridge.install
@@ -5,18 +5,18 @@ post_install() {
getent passwd ${_NAME} > /dev/null || useradd -d /var/lib/${_NAME} -s /bin/false -r ${_NAME} > /dev/null
chown -R ${_NAME}:${_NAME} /var/lib/${_NAME}
- echo ""
- echo "A sample configuration file is provided at /usr/lib/node_modules/homebridge/config-sample.json"
- echo "Copy this to /var/lib/${_NAME}/config.json and edit accordingly"
- echo " cp /usr/lib/node_modules/homebridge/config-sample.json /var/lib/${_NAME}/config.json"
- echo " chown ${_NAME}:${_NAME} /var/lib/${_NAME}/config.json"
- echo " \$EDITOR /var/lib/${_NAME}/config.json"
- echo ""
- echo "You can then start the service as follows:"
- echo " systemctl start homebridge"
- echo ""
- echo "If you get a DNS related error on startup, make sure avahi-daemon is running (systemctl status -l avahi-daemon.service)"
- echo ""
+ echo ""
+ echo "A sample configuration file is provided at /usr/lib/node_modules/homebridge/config-sample.json"
+ echo "Copy this to /var/lib/${_NAME}/config.json and edit accordingly"
+ echo " cp /usr/lib/node_modules/homebridge/config-sample.json /var/lib/${_NAME}/config.json"
+ echo " chown ${_NAME}:${_NAME} /var/lib/${_NAME}/config.json"
+ echo " \$EDITOR /var/lib/${_NAME}/config.json"
+ echo ""
+ echo "You can then start the service as follows:"
+ echo " systemctl start homebridge"
+ echo ""
+ echo "If you get a DNS related error on startup, make sure avahi-daemon is running (systemctl status -l avahi-daemon.service)"
+ echo ""
}
post_upgrade() {