summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHenning Surmeier2018-11-07 00:13:06 +0100
committerHenning Surmeier2018-11-07 00:13:06 +0100
commitbc55167cbe95673f814c29c7218ae57e1ee8265f (patch)
treefbcec344bdb00e5a1cc69582f116b51d7c635f59
parentf8ea9859146b4cf06cae8495a95b32e9f0b9d1ce (diff)
downloadaur-bc55167cbe95673f814c29c7218ae57e1ee8265f.tar.gz
rework config and directory structure
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD21
-rw-r--r--homegear-config.patch128
-rw-r--r--homegear-php.patch37
4 files changed, 127 insertions, 63 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f9f2f384a3e8..1e8f23e081b9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = homegear
pkgdesc = Interface your HomeMatic BidCoS, HomeMatic Wired, MAX!, INSTEON or Philips hue devices with your home automation software or your own control scripts
pkgver = 0.7.30
- pkgrel = 1
+ pkgrel = 2
url = https://homegear.eu
install = homegear.install
arch = x86_64
@@ -46,7 +46,7 @@ pkgbase = homegear
sha512sums = aed267cb77c6a23a563152a17781cbe12fe14b68ed3d77dc75145c6422c3818f0d3550b5d20609d06e0bf937f24627806c0bfb3201fd27da0b420f6fbd4ebc66
sha512sums = 23fb3b1a49f7b3433bd71ca262545aa31d67e7ae88801b41a7c1e306be926a06b7b29389cc63f3342cf8f5e55f908dc0847be6ba7d6b2657018240883a658ce0
sha512sums = b603487c3273c3e7abd9a4ad28ace16d309ef59750ea29737f5d93bbd607cfe322c6f79f68a555ed6fee7370d319ac9be3ff284794caad3be1ebb24f5b792647
- sha512sums = 4dbe1a9999ba8331f9f8debd7e7d761e4f6d08538c8f9cfc1cb7d22b450313156e49a977710ff1e18e7b322d70ed1280da1d5f18da2033d33e871a0b3a701ed8
+ sha512sums = 2681aa09982b621161c5d082064d4188dc97b738ffd8fa24e615bf22b338902d45c06d229ea480df80cc48878294d24325552a959d72649a1a4bd1adadb8ba41
sha512sums = 5b25817cbbf5a5fb1d7c8414d36441de18cef3c43693329facb84b4312fd83c92bfcf6100937f3e5c9a7329e4ba80de1418cc0b9374c46d14255a612e8617498
pkgname = homegear
diff --git a/PKGBUILD b/PKGBUILD
index 7020313a3f16..876bf2e87bbf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,13 @@
# Package build for homegear (https://www.homegear.eu/index.php/Main_Page)
-# Maintainer: Niklas <dev@n1klas.net>
+# Maintainer: Henning <me@hensur.de>
+# Contributor: Niklas <dev@n1klas.net>
# Contributor: Michael Lipp <mnl at mnl dot de>
pkgname='homegear'
_gitname='Homegear'
pkgdesc='Interface your HomeMatic BidCoS, HomeMatic Wired, MAX!, INSTEON or Philips hue devices with your home automation software or your own control scripts'
pkgver=0.7.30
-pkgrel=1
+pkgrel=2
arch=('x86_64' 'i686' 'armv6h' 'armv7h' 'aarch64')
license=('LGPL3')
url="https://homegear.eu"
@@ -31,7 +32,7 @@ sha512sums=('8f8065b05863b2c6e634cfadb982efe5f2281c616f47c1a0794642de9cec8d49dec
'aed267cb77c6a23a563152a17781cbe12fe14b68ed3d77dc75145c6422c3818f0d3550b5d20609d06e0bf937f24627806c0bfb3201fd27da0b420f6fbd4ebc66'
'23fb3b1a49f7b3433bd71ca262545aa31d67e7ae88801b41a7c1e306be926a06b7b29389cc63f3342cf8f5e55f908dc0847be6ba7d6b2657018240883a658ce0'
'b603487c3273c3e7abd9a4ad28ace16d309ef59750ea29737f5d93bbd607cfe322c6f79f68a555ed6fee7370d319ac9be3ff284794caad3be1ebb24f5b792647'
- '4dbe1a9999ba8331f9f8debd7e7d761e4f6d08538c8f9cfc1cb7d22b450313156e49a977710ff1e18e7b322d70ed1280da1d5f18da2033d33e871a0b3a701ed8'
+ '2681aa09982b621161c5d082064d4188dc97b738ffd8fa24e615bf22b338902d45c06d229ea480df80cc48878294d24325552a959d72649a1a4bd1adadb8ba41'
'5b25817cbbf5a5fb1d7c8414d36441de18cef3c43693329facb84b4312fd83c92bfcf6100937f3e5c9a7329e4ba80de1418cc0b9374c46d14255a612e8617498')
install='homegear.install'
backup=('etc/homegear/main.conf'
@@ -80,12 +81,16 @@ package() {
install -dm750 "${pkgdir}/var/lib/homegear"
install -dm755 "${pkgdir}/var/log/homegear"
- cp -r "misc/State Directory/"* "${pkgdir}/var/lib/homegear"
- find "${pkgdir}/var/lib/homegear/www" -type d -exec chmod 550 {} \;
- find "${pkgdir}/var/lib/homegear/www" -type f -exec chmod 440 {} \;
- install -dm750 "${pkgdir}/var/lib/homegear/flows/data"
+ cp -r "misc/State Directory/"{node-blue,www} "${pkgdir}/usr/lib/homegear"
+ cp -r "misc/State Directory/scripts" "${pkgdir}/var/lib/homegear"
+ find "${pkgdir}/usr/lib/homegear/www" -type d -exec chmod 755 {} \;
+ find "${pkgdir}/usr/lib/homegear/node-blue" -type d -exec chmod 755 {} \;
+ find "${pkgdir}/usr/lib/homegear/www" -type f -exec chmod 644 {} \;
+ find "${pkgdir}/usr/lib/homegear/node-blue" -type f -exec chmod 644 {} \;
+ install -dm750 "${pkgdir}/var/lib/homegear/node-blue/data"
install -dm750 "${pkgdir}/var/lib/homegear/phpinclude"
- install -dm550 "${pkgdir}/var/lib/homegear/scripts"
+ install -dm750 "${pkgdir}/var/lib/homegear/scripts"
+ install -dm750 "${pkgdir}/var/lib/homegear/tmp"
install -dm750 "${pkgdir}/var/lib/homegear/firmware"
install -dm755 "${pkgdir}"/etc/homegear/devices/254
diff --git a/homegear-config.patch b/homegear-config.patch
index 1daf198f1b5a..77ebbb50dce1 100644
--- a/homegear-config.patch
+++ b/homegear-config.patch
@@ -1,5 +1,5 @@
diff --git a/misc/Config Directory/main.conf b/misc/Config Directory/main.conf
-index a5df031..b9baf7f 100644
+index a5df031..9ae319e 100644
--- a/misc/Config Directory/main.conf
+++ b/misc/Config Directory/main.conf
@@ -2,10 +2,10 @@
@@ -24,24 +24,28 @@ index a5df031..b9baf7f 100644
# If dataPath is empty, the executable path is used.
# Default: dataPath =
-@@ -165,7 +165,7 @@ enableNodeBlue = true
+@@ -164,17 +164,17 @@ scriptPath = /var/lib/homegear/scripts
+ enableNodeBlue = true
# Path where Node-BLUE is located.
- # Default: nodeBluePath = /var/lib/homegear/node-blue
+-# Default: nodeBluePath = /var/lib/homegear/node-blue
-nodeBluePath = /var/lib/homegear/node-blue
++# Default: nodeBluePath = /usr/lib/homegear/node-blue
+nodeBluePath = /usr/lib/homegear/node-blue
# Default: nodeBluePathPermissions = 770
# nodeBluePathPermissions = 770
-@@ -178,7 +178,7 @@ nodeBluePath = /var/lib/homegear/node-blue
+
+ # Default: nodeBluePathUser =
+-# nodeBluePathUser = homegear
++nodeBluePathUser = homegear
+
+ # Default: nodeBluePathGroup =
+-# nodeBluePathGroup = homegear
++nodeBluePathGroup = homegear
# Path where flow data is stored.
# Default: nodeBlueDataPath = /var/lib/homegear/node-blue/data
--nodeBlueDataPath = /var/lib/homegear/node-blue/data
-+nodeBlueDataPath = /usr/lib/homegear/node-blue/data
-
- # Default: nodeBlueDataPathPermissions = 770
- # nodeBlueDataPathPermissions = 770
@@ -194,8 +194,8 @@ nodeBlueDataPath = /var/lib/homegear/node-blue/data
nodeBlueDebugOutput = true
@@ -64,24 +68,24 @@ index a5df031..b9baf7f 100644
# Default: uiPathPermissions = 770
# uiPathPermissions = 770
-@@ -221,21 +221,21 @@ uiPath = /var/lib/homegear/ui
+@@ -220,12 +220,12 @@ uiPath = /var/lib/homegear/ui
+ # uiPathGroup = homegear
# Path to the family modules.
- # Default: modulePath = /var/lib/homegear/modules
+-# Default: modulePath = /var/lib/homegear/modules
-modulePath = /var/lib/homegear/modules
++# Default: modulePath = /usr/lib/homegear/modules
+modulePath = /usr/lib/homegear/modules
# Path to the directory with firmware updates
- # Default: firmwarePath = /usr/share/homegear/firmware
+-# Default: firmwarePath = /usr/share/homegear/firmware
-firmwarePath = /usr/share/homegear/firmware
++# Default: firmwarePath = /var/lib/homegear/firmware
+firmwarePath = /var/lib/homegear/firmware
# Path to a directory where Homegear can store temporary data
# Default: tempPath = /var/lib/homegear/tmp
--tempPath = /var/lib/homegear/tmp
-+tempPath = /tmp/homegear
-
- # If lockFilePath is empty, the executable path is used. If unset, "/var/lock" is used.
+@@ -235,7 +235,7 @@ tempPath = /var/lib/homegear/tmp
# Default: lockFilePath = /var/lock
# /var/run/ is not the correct path for lock files. But as /var/lock is not user-writeable
# on some systems, we decided to move the lock files to /var/run/homegear.
@@ -90,3 +94,95 @@ index a5df031..b9baf7f 100644
# If unset permissions are not set on start of Homegear.
# Default: lockFilePathPermissions = 770
+diff --git a/misc/Config Directory/rpcservers.conf b/misc/Config Directory/rpcservers.conf
+index 833770c..c7c9e7b 100644
+--- a/misc/Config Directory/rpcservers.conf
++++ b/misc/Config Directory/rpcservers.conf
+@@ -24,17 +24,17 @@ webServer = true
+ restServer = true
+
+ # Path to static web content used by the web server
+-# Default: /var/lib/homegear/www
+-contentPath = /var/lib/homegear/www/rpc
++# Default: /usr/lib/homegear/www/rpc
++contentPath = /usr/lib/homegear/www/rpc
+
+ # Default: contentPathPermissions = 550
+ # contentPathPermissions = 550
+
+ # Default: contentPathUser =
+-# contentPathUser = homegear
++contentPathUser = homegear
+
+ # Default: contentPathGroup =
+-# contentPathGroup = homegear
++contentPathGroup = homegear
+
+ # Enable Homegear's build-in WebSocket server on this port
+ # WARNING: Enabling Websockets without authentication is a high security risk!
+@@ -95,17 +95,17 @@ webServer = true
+ restServer = true
+
+ # Path to static web content used by the web server
+-# Default: /var/lib/homegear/www
+-contentPath = /var/lib/homegear/www/rpc
++# Default: /usr/lib/homegear/www/rpc
++contentPath = /usr/lib/homegear/www/rpc
+
+ # Default: contentPathPermissions = 550
+ # contentPathPermissions = 550
+
+ # Default: contentPathUser =
+-# contentPathUser = homegear
++contentPathUser = homegear
+
+ # Default: contentPathGroup =
+-# contentPathGroup = homegear
++contentPathGroup = homegear
+
+ # Enable Homegear's build-in WebSocket server on this port
+ # WARNING: Enabling Websockets without authentication is a high security risk!
+@@ -178,17 +178,17 @@ webServer = true
+ restServer = true
+
+ # Path to static web content used by the web server
+-# Default: /var/lib/homegear/www
+-contentPath = /var/lib/homegear/www/rpc
++# Default: /usr/lib/homegear/www
++contentPath = /usr/lib/homegear/www/rpc
+
+ # Default: contentPathPermissions = 550
+ # contentPathPermissions = 550
+
+ # Default: contentPathUser =
+-# contentPathUser = homegear
++contentPathUser = homegear
+
+ # Default: contentPathGroup =
+-# contentPathGroup = homegear
++contentPathGroup = homegear
+
+ # Enable Homegear's build-in WebSocket server on this port
+ # Default: false
+@@ -256,8 +256,8 @@ validGroups = 1
+ #restServer = true
+
+ # Path to static web content used by the web server
+-# Default: /var/lib/homegear/www
+-#contentPath = /var/lib/homegear/www
++# Default: /usr/lib/homegear/www
++# contentPath = /usr/lib/homegear/www
+
+ # Default: contentPathPermissions = 550
+ # contentPathPermissions = 550
+@@ -326,8 +326,8 @@ cacheAssets = 2592000
+ #restServer = true
+
+ # Path to static web content used by the web server
+-# Default: /var/lib/homegear/www
+-#contentPath = /var/lib/homegear/www
++# Default: /usr/lib/homegear/www
++#contentPath = /usr/lib/homegear/www
+
+ # Default: contentPathPermissions = 550
+ # contentPathPermissions = 550
diff --git a/homegear-php.patch b/homegear-php.patch
deleted file mode 100644
index cef7e214c107..000000000000
--- a/homegear-php.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-diff --git a/src/Makefile.am b/src/Makefile.am
-index 5342ae3..5dcbdd6 100644
---- a/src/Makefile.am
-+++ b/src/Makefile.am
-@@ -4,7 +4,7 @@ AM_CPPFLAGS = -Wall -std=c++11 -DFORTIFY_SOURCE=2 -DGCRYPT_NO_DEPRECATED
- AM_LDFLAGS = -Wl,-rpath=/lib/homegear -Wl,-rpath=/usr/lib/homegear -Wl,-rpath=/usr/local/lib/homegear
- if HAVE_PHP_HEADERS
- # {{{ PHP libraries
--LIBS += -Wl,-Bstatic -lphp7-homegear -Wl,-Bdynamic -lz -lexslt -lresolv -ledit -lrt -lmcrypt -lltdl -lgmp -lenchant -lrt -lm -lnsl -lxml2 -lxslt -lcrypt -lcrypto -lssl -lgnutls
-+LIBS += -Wl,-Bstatic -lphp-homegear -Wl,-Bdynamic -lz -lexslt -lresolv -ledit -lrt -lmcrypt -lltdl -lgmp -lenchant -lrt -lm -lnsl -lxml2 -lxslt -lcrypt -lcrypto -lssl -lgnutls
- # }}}
- endif
-
-@@ -34,8 +34,8 @@ libscriptengine_a_SOURCES = ScriptEngine/php_homegear_globals.cpp ScriptEngine/p
- homegear_LDADD += libscriptengine.a
- libscriptengine_a_CPPFLAGS = -Wall -std=c++11 -DFORTIFY_SOURCE=2 -DGCRYPT_NO_DEPRECATED
- if BSDSYSTEM
--libscriptengine_a_CPPFLAGS += -I/usr/include/php7-homegear -I/usr/include/php7-homegear/main -I/usr/include/php7-homegear/sapi -I/usr/include/php7-homegear/TSRM -I/usr/include/php7-homegear/Zend -I/usr/include/php7-homegear/php -I/usr/include/php7-homegear/php/main -I/usr/include/php7-homegear/php/sapi -I/usr/include/php7-homegear/php/TSRM -I/usr/include/php7-homegear/php/Zend
-+libscriptengine_a_CPPFLAGS += -I/usr/include/php-homegear -I/usr/include/php-homegear/main -I/usr/include/php-homegear/sapi -I/usr/include/php-homegear/TSRM -I/usr/include/php-homegear/Zend -I/usr/include/php-homegear/php -I/usr/include/php-homegear/php/main -I/usr/include/php-homegear/php/sapi -I/usr/include/php-homegear/php/TSRM -I/usr/include/php-homegear/php/Zend
- else
--libscriptengine_a_CPPFLAGS += -I/usr/include/php7-homegear -I/usr/include/php7-homegear/main -I/usr/include/php7-homegear/sapi -I/usr/include/php7-homegear/TSRM -I/usr/include/php7-homegear/Zend -I/usr/include/php7-homegear/php -I/usr/include/php7-homegear/php/main -I/usr/include/php7-homegear/php/sapi -I/usr/include/php7-homegear/php/TSRM -I/usr/include/php7-homegear/php/Zend
-+libscriptengine_a_CPPFLAGS += -I/usr/include/php-homegear -I/usr/include/php-homegear/main -I/usr/include/php-homegear/sapi -I/usr/include/php-homegear/TSRM -I/usr/include/php-homegear/Zend -I/usr/include/php-homegear/php -I/usr/include/php-homegear/php/main -I/usr/include/php-homegear/php/sapi -I/usr/include/php-homegear/php/TSRM -I/usr/include/php-homegear/php/Zend
- endif
- #endif
-diff --git a/configure.ac b/configure.ac
-index 399a410..296d433 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -70,7 +70,7 @@ esac
- AC_CHECK_LIB([mysqlclient], [mysql_init], [AM_CONDITIONAL(HAVE_MYSQLCLIENT, true)], [AM_CONDITIONAL(HAVE_MYSQLCLIENT, false)])
- AC_CHECK_HEADERS([curl/curl.h], [AM_CONDITIONAL(HAVE_CURL_HEADERS, true)], [AM_CONDITIONAL(HAVE_CURL_HEADERS, false)])
- AC_CHECK_LIB([curl], [curl_easy_send], [AM_CONDITIONAL(HAVE_CURL, true)], [AM_CONDITIONAL(HAVE_CURL, false)])
--AC_CHECK_HEADERS([php7-homegear/main/php_config.h], [AM_CONDITIONAL(HAVE_PHP_HEADERS, true)], [AM_CONDITIONAL(HAVE_PHP_HEADERS, false)])
-+AC_CHECK_HEADERS([php-homegear/main/php_config.h], [AM_CONDITIONAL(HAVE_PHP_HEADERS, true)], [AM_CONDITIONAL(HAVE_PHP_HEADERS, false)])
-
- AC_DEFINE_UNQUOTED([GITCOMMITSHABASE], [`./getGitCommitBase.sh`], [Define git commit SHA of libhomegear-base])
- AC_DEFINE_UNQUOTED([GITCOMMITSHAHOMEGEAR], [`./getGitCommitHomegear.sh`], [Define git commit SHA of Homegear])