summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarek Kubica2013-09-02 01:20:49 +0200
committerMarek Kubica2013-09-02 01:20:49 +0200
commitff35dbedbb25d424c3b00cca735cdbd1f11979dd (patch)
tree9fc894885295ec02bf748fc2e1967b8f8a2f5be3
parent72bb217c99a1f1671ef3eaa45a741a1636d1febe (diff)
downloadaur-ff35dbedbb25d424c3b00cca735cdbd1f11979dd.tar.gz
Adjust to current best-practice Ruby PKGBUILD guidelines
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cc312af2ab90..dbf72aa35c05 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,6 @@
# Contributor: Leonidas <marek@xivilization.net>
-pkgname=homesick
+_gemname=homesick
+pkgname=${_gemname}
pkgver=0.9.4
pkgrel=1
pkgdesc="A man's home is his castle. Never leave your dotfiles behind."
@@ -13,10 +14,10 @@ source=(http://rubygems.org/downloads/${pkgname}-${pkgver}.gem)
noextract=(${pkgname}-${pkgver}.gem)
sha512sums=('6f4914752f9483a0bb56f53df3a7ca435407c9f30352ae554ac63e35074979236ebaa666b24f4fd76ff741e633c8533390396700320733e79bc79486c571c808')
-build() {
- cd $srcdir
- # _gemdir is defined inside build() because if ruby[gems] is not installed on the system
- # makepkg will barf when sourcing the PKGBUILD
+package() {
+ cd "${srcdir}"
+ # _gemdir is defined inside package() because if ruby[gems] is not installed on
+ # the system makepkg will barf when sourcing the PKGBUILD.
local _gemdir="$(ruby -rubygems -e'puts Gem.default_dir')"
# we want to write the 'homesick' binary to the $PATH
local _bindir="${pkgdir}/usr/bin"