summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkaptoxic2015-09-07 19:16:25 -0400
committerkaptoxic2015-09-07 19:16:25 -0400
commit5e98c7dc784a256464e959a455f44ebde1b684a4 (patch)
tree26f27273b9083bb74933a58848ca63a5fbef034f
downloadaur-5e98c7dc784a256464e959a455f44ebde1b684a4.tar.gz
Initial import
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD73
-rw-r--r--hon.desktop11
-rw-r--r--hon.install18
-rw-r--r--license328
5 files changed, 457 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a28e199fa4d7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = hon
+ pkgdesc = Heroes of Newerth is a Real Time Strategy game heavily influcenced by DotA
+ pkgver = 3.6.4.1
+ pkgrel = 2
+ url = http://www.heroesofnewerth.com/
+ install = hon.install
+ arch = i686
+ arch = x86_64
+ license = custom:HoN
+ makedepends = unzip
+ depends = alsa-lib
+ depends = gconf
+ depends = gtk2
+ depends = nss
+ depends = libxss
+ depends = libjpeg-turbo
+ noextract = HoNClient-3.6.4.1.sh
+ options = !strip
+ source = hon.desktop
+ source = license
+ source = http://dl.heroesofnewerth.com/HoNClient-3.6.4.1-2.sh
+ md5sums = 25fb5ab8c49be0f1269c79520ccee789
+ md5sums = dd2c8cd0f5bcafa25cfb583a92e21aec
+ md5sums = 0e802185477b5158877195a3aff8669e
+
+pkgname = hon
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f367fbc4b9ab
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,73 @@
+# Maintainer: <kaptoxic _at_ yahoo _dot_ com >
+# Contributor: Daniel Dias <dias AT archlinux DOT info>
+# Contributor: Aaron Fischer <mail@aaron-fischer.net>
+# Contributor: Slash <yahoo.com: demodevil5>
+# Contributor: Jesse Jaara <gmail.com: jesse.jaara>
+
+# To speed up package creation. If you are planning to distribute
+# This on some custon repo, you might want to use the defaut slow but
+# much better xz compression.
+PKGEXT=.pkg.tar
+
+pkgname=hon
+pkgver=3.6.4.1
+pkgrel=2
+pkgdesc="Heroes of Newerth is a Real Time Strategy game heavily influcenced by DotA"
+arch=('i686' 'x86_64')
+url="http://www.heroesofnewerth.com/"
+license=('custom:HoN')
+depends=('alsa-lib' 'gconf' 'gtk2' 'nss' 'libxss' 'libjpeg-turbo')
+makedepends=('unzip')
+options=(!strip)
+install=hon.install
+source=('hon.desktop' 'license' "http://dl.heroesofnewerth.com/HoNClient-${pkgver}-${pkgrel}.sh")
+noextract=("HoNClient-${pkgver}.sh")
+md5sums=('25fb5ab8c49be0f1269c79520ccee789'
+ 'dd2c8cd0f5bcafa25cfb583a92e21aec'
+ '0e802185477b5158877195a3aff8669e')
+
+package() {
+ ## Thx to messo8080 for reminding us about the /tmp dir,
+ ## on new installs this dir is in ram by default.
+
+ if `pwd | grep -q "/tmp"`; then
+ echo \
+"You are trying to build this pkg in /tmp dir.
+This is not so good idea as /tmp dir is in ram
+by default. If you know that you have lots of
+ram (>4G) and swap and want to continue building in
+the current directory write yes and press ENTER.
+Otherwise write no and press ENTER.
+Continue?"
+ read answer
+ if [ "${answer}" == "no" ]; then
+ false
+ fi
+ fi
+
+ mv HoNClient-${pkgver}-${pkgrel}.sh HoNClient-${pkgver}.sh
+
+ # Create Destination Directory
+ mkdir -p "${pkgdir}/opt/"
+ mkdir -p "${pkgdir}/usr/share/licenses/${pkgname}"
+
+ # Extract Files
+ sh -c "unzip \"${srcdir}/HoNClient-${pkgver}.sh\" \"data/*\" -d \"${pkgdir}/opt/\"; true"
+ mv "${pkgdir}"/opt/{data,hon}
+
+ # Install License
+ cp "${srcdir}/license" "${pkgdir}/usr/share/licenses/${pkgname}/"
+
+ # Install Desktop Shortcut
+ install -D -m 0644 "${srcdir}/hon.desktop" \
+ "${pkgdir}/usr/share/applications/hon.desktop"
+
+ # Install Client Launcher
+ mkdir -p "${pkgdir}/usr/bin"
+ ln -s /opt/hon/hon.sh "${pkgdir}/usr/bin/hon"
+
+ # Set Ownership to root:games
+ chown -R root:games "${pkgdir}/opt/hon"
+ chmod -R g+w "${pkgdir}/opt/hon"
+}
+
diff --git a/hon.desktop b/hon.desktop
new file mode 100644
index 000000000000..96cce0fd2b9b
--- /dev/null
+++ b/hon.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=Heroes of Newerth
+GenericName=Heroes of Newerth
+Comment=
+Exec=/usr/bin/hon
+Icon=/opt/hon/honicon_128x128.png
+StartupNotify=true
+Terminal=false
+Type=Application
+Categories=Application;Game
diff --git a/hon.install b/hon.install
new file mode 100644
index 000000000000..234fa5c21f35
--- /dev/null
+++ b/hon.install
@@ -0,0 +1,18 @@
+
+post_install() {
+ echo ">>> You must read and agree to the terms in the EULAs found"
+ echo ">>> in /usr/share/licenses/hon/ before using this software!"
+ echo ">>>"
+ echo ">>> In order to play Heroes of Newerth, add your user to the 'games' group."
+ echo ">>> # gpasswd -a USERNAME games"
+ echo ">>> Remember to logout and log back in for the changes to take effect."
+ echo ">>> Nvidia user might need to do the following."
+ echo -e ">>> Append the following 3 lines to \"~/.Heroes of Newerth/game/startup.cfg\""
+ echo -e "SetSave \"vid_bpp\" \"32\""
+ echo -e "SetSave \"vid_refreshRate\" \"60\""
+ echo -e "SetSave \"vid_resolution\" \"1280,1024\""
+}
+
+post_upgrade() {
+ post_install $1
+}
diff --git a/license b/license
new file mode 100644
index 000000000000..e94f30d61dc5
--- /dev/null
+++ b/license
@@ -0,0 +1,328 @@
+S2 Games Heroes of Newerth Account Terms of Service
+
+----------------------------------------------------------------------
+
+THIS SOFTWARE IS LICENSED, NOT SOLD. BY INSTALLING, COPYING OR OTHERWISE USING
+THE GAME (DEFINED BELOW), YOU AGREE TO BE BOUND BY THE TERMS OF THIS AGREEMENT.
+IF YOU DO NOT AGREE TO THE TERMS OF THIS AGREEMENT, YOU ARE NOT PERMITTED TO
+INSTALL, COPY OR USE THE GAME.
+
+Heroes of Newerth (hereinafter "HoN") is composed of the software program, and
+any files that are delivered to you by S2 Games, LLC (herein referred to as S2
+or S2 Games), via on-line transmission or otherwise, to "patch," update, or
+otherwise modify the software program, as well as any printed materials and any
+on-line or electronic documentation (the "Manual"), and any and all copies and
+derivative works of such software program and Manual (collectively, the "Game")
+and is the copyrighted work of S2 Games, LLC and its subsidiaries, affiliates or
+its licensors. The website, http://www.heroesofnewerth.com, all related sites,
+online play environments, including but not limited to S2 servers, and related
+activities in and of S2 Games, are the sole and exclusive property of S2 Games,
+LLC. Your use of S2 games and services is subject at all times to these Terms of
+Service (TOS), or Privacy Policy (PP) and/or our Beta Policy (BP) which are
+incorporated herein by reference.
+
+The Game is distributed solely for use by authorized end users according to the
+provisions of this TOS. Any use, reproduction, modification or distribution of
+the Game not expressly authorized by the terms of the TOS, or without the prior
+written consent of S2, is expressly prohibited.
+
+If you have questions about the Terms of Service, please contact us by sending
+an email to TOS@s2games.com
+
+1. Heroes of Newerth Online Account Registration
+
+In order to use the service and the Game, you will be required to establish a
+separate account (your "Account") on S2's centralized account system. When
+creating these accounts, you may be required to provide S2 with certain personal
+information, financial information and an unused Authentication Key provided to
+you by S2. You agree that you will supply accurate information to S2 when
+requested, and that you will update that information promptly after it changes.
+
+A. During the registration process, you may be required to select a unique
+username and a password (collectively referred to hereunder as
+"Login Information"). You may not share the Account or the Login Information
+with anyone other than as expressly set forth herein. S2 will not ask you to
+reveal your password or ever initiate any contact with you asking for your
+reminder words. (If you forget your password, you can tell us your reminder
+words and we will send you your password.)
+
+B. NOTWITHSTANDING ANYTHING TO THE CONTRARY HEREIN, YOU ACKNOWLEDGE AND
+AGREE THAT YOU SHALL HAVE NO OWNERSHIP OR OTHER PROPERTY INTEREST IN THE
+ACCOUNT, AND YOU FURTHER ACKNOWLEDGE AND AGREE THAT ALL RIGHTS IN AND TO THE
+ACCOUNT ARE AND SHALL FOREVER BE OWNED BY AND INURE TO THE BENEFIT OF S2.
+
+C. S2 MAY SUSPEND, TERMINATE, MODIFY, OR DELETE ACCOUNTS AT ANY TIME FOR
+ANY REASON OR FOR NO REASON, WITH OR WITHOUT NOTICE TO YOU. For purposes of
+explanation and not limitation, most account suspensions, terminations and/or
+deletions are the result of violations of this Terms of Service.
+
+D. You are solely responsible for all activity on your Account and for the
+security of your computer system. You agree to indemnify and hold S2 harmless
+for any improper or illegal use of your Account.
+
+S2 does not recognize the transfer of S2 or HoN accounts. You may not purchase,
+sell, gift or trade any Account, or offer to purchase, sell, gift or trade any
+Account, and any such attempt shall be null and void. S2 owns, has licensed, or
+otherwise has rights to all of the content that appears in the Game. You agree
+that you have no right or title in or to any such content, or any other
+attributes associated with the Account or stored on the Service.
+
+2. Content
+
+S2, our Members, our affiliates, and our independent content providers provide
+most of the Content on S2. S2 does not pre-screen all Content. You bear the
+entire risk of the completeness, accuracy or usefulness of Content found on S2.
+
+Strong vulgar language, hate speech, crude or explicit sexual references,
+discussions of illegal drugs, terrorist plots, and subversive behavior are
+inappropriate Some game play and chat rooms may involve use of stronger language
+than others, including mild expletives. Always use your best judgment in online
+conduct. If you would not say something in a room full of people you have never
+met, or in the workplace, don't post it on our message boards or chat.
+
+S2 does not endorse, approve, or prescreen any Content that you or other users
+communicate on the Service. S2 does not assume any responsibility or liability
+for Content that is generated by Members or other guests on S2. We reserve the
+right to remove Content that is objectionable to us for any reason. This
+determination is in our sole discretion, and is final. S2 does not assume any
+liability for any failure to remove, or any delay in removing Content.
+
+If we removed Content that you created, we may send you a warning. If it's a
+serious offense or you've violated our rules before, we may ban you from
+participating on S2 and terminate your Account.
+
+3. Online Conduct
+
+Online conduct should be guided by common sense and basic etiquette. The laws
+that apply in the offline world must be obeyed online as well. We have zero
+tolerance for illegal behavior at S2. You must also obey rules for use of third
+party tools, and rules of interactive service providers, state, local, federal
+laws, or foreign or international law where appropriate. Ignorance of the law is
+no excuse. We terminate use of the Game and any related services and cooperate
+with law enforcement for illegal behavior.
+
+You agree that you will be personally responsible for your use of HoN and the
+Service and for all of your communication and activity on the Service, including
+any Content you contribute, and that you will indemnify and hold harmless S2.,
+its affiliates, employees, officers, and directors from any liability or damages
+arising from your conduct on S2, including any Content that you contribute.
+
+The following rules are not meant to be exhaustive, and S2 reserves the right to
+determine which conduct it considers to be outside the spirit of the Game and to
+take such disciplinary measures as it sees fit up to and including termination
+and deletion of the Account. S2 reserves the right to modify this Terms of
+Service at any time.
+
+You will violate the Terms of Service if you (or others using your Account) do
+any of the following:
+
+** Harass, threaten, embarrass, or do anything else to another Member or guest
+that is unwanted.
+
+** Transmit or facilitate distribution of Content that is harmful, abusive,
+racially or ethnically offensive, vulgar, sexually explicit, defamatory,
+infringing, invasive of personal privacy or publicity rights, or in a reasonable
+person's view, objectionable. Hate speech is not tolerated.
+
+** Impersonate another person (including celebrities), indicate that you are an
+S2 employee or a representative of S2.
+
+** Upload any software or Content that you do not own or have permission to
+freely distribute.
+
+** Promote or encourage any illegal activity including hacking, cracking or
+distribution of counterfeit software.
+
+** Post, transmit, promote, or distribute Content that is illegal.
+
+** Upload files that contain a virus or corrupted data.
+
+** Post messages for any purpose other than personal communication, including
+without limitation advertising, promotional materials, chain letters, pyramid
+schemes, or make any commercial use of our Service.
+
+** Use or distribute "auto" software programs, "macro" software programs or
+other "cheat utility" software program or applications.
+
+** You must obey all applicable laws, regulations and rules wherever you are on
+the Service. This includes rules for use of third-party technology and content,
+rules of interactive service providers, and federal, state, local and foreign
+laws where applicable. Ignorance of the law is no excuse. The laws that apply
+in the offline world must be obeyed online as well. We have zero tolerance for
+illegal behavior on the Service. We will cooperate with law enforcement in such
+matters.
+
+** You will not exploit any bug in S2's product to gain unfair advantage in the
+game and you will not communicate the existence of any such bug (either directly
+or through the public posting) to any other user of the Service.
+
+
+
+If you encounter another user of the Service who is violating any of the Rules
+of Conduct described above, please report them using the "Help" or
+"Report Abuse" functions of the Service.
+
+4. Commercial Activity and Unsolicited E-mail.
+
+You may not advertise any goods or services on S2. Chain letters and pyramid
+schemes are not allowed. You may not use any area of S2 to collect information,
+including login names, about S2 Members, and use of such information to send
+unsolicited e-mail or for any other purpose is strictly prohibited. You may not
+exploit S2, or any games or services offered on S2 for any commercial purpose.
+Any violation of these provisions can subject your S2 Account(s) to immediate
+termination (or result in revocation of Guest status, if you are a guest) and
+further legal action.
+
+5. Changes to the Terms of Service Agreement, the Game or S2 Services and
+Servers.
+
+S2 reserves the right, at its sole and absolute discretion, to change, modify,
+add to, supplement or delete any of the terms and conditions of this Agreement
+at any time, including without limitation access policies, the availability of
+any feature of the Game or the Service (including S2 servers), hours of
+availability, content, data, software or equipment needed to access the Game or
+the Service, effective with or without prior notice; provided, however, that
+material changes (as determined in S2's sole and absolute discretion) will be
+disclosed as follows: S2 will provide you with notification of any such changes
+through a patch process, or by email, forum posting, postal mail, website
+posting, pop-up screen, or in-game notice. If any future changes to this
+Agreement are unacceptable to you or cause you to no longer be in compliance
+with this Agreement, you must terminate, and immediately stop using, the Game
+and the Account. Your continued use of the Game following any revision to this
+Agreement constitutes your complete and irrevocable acceptance of any and all
+such changes. S2 may change, modify, suspend, or discontinue any aspect of the
+Game, including but not limited to adding or subtracting S2 game servers, at any
+time. S2 may also impose limits on certain features or restrict your access to
+parts or all of the Game without notice or liability.
+
+6. Alpha / Beta Policy
+
+If you have been selected to the alpha or beta program for any of S2's products
+you do so under the following express conditions:
+
+Alpha/beta tests are strictly confidential. The games, including information
+about features and functionality to be offered as part of the games, are
+confidential. If you participate in a alpha/beta test, you will use your
+best efforts to safeguard and to prevent unauthorized access to, copying,
+disclosure, and unauthorized use of the beta games. In addition no recordings,
+no screenshots, no assets grabs of any type will be permitted. You will carry
+out the testing personally and not provide access to beta games to any other
+person. You agree that breach of the above confidentiality obligations will
+cause irreparable harm to S2, and S2 is entitled to (in addition to any other
+remedies available to it) ex parte injunctive relief without bond to prevent the
+breach or threatened breach of your obligations. In addition, your retail
+account for Heroes of Newerth will be terminated immediately.
+
+By starting an alpha/beta game, you agree that: Playing alpha/beta games is at
+your own risk and that you know that the games may include known or unknown
+bugs, Any value or status indicators that you achieve through game play may be
+erased at any time, S2's TOS applies to your use of the games during the testing
+phase, and, you will keep all information about the alpha/beta games
+confidential as stated above and not disclose such information to any other
+person. User's Computer Information. When you connect to S2 for the alpha/beta
+test, we will retrieve information from the computer used to log onto the beta
+test about the computer's hardware system and any data related to the computer's
+operation of S2. We will not collect any personal information about you,
+however, without your knowledge and consent as stated in our PP.
+
+7. Disclaimer of Warranty
+
+THE GAME AND THE SERVICE ARE PROVIDED "AS IS" AND S2 DOES NOT WARRANT THAT THE
+GAME OR THE SERVICE WILL BE UNINTERRUPTED OR ERROR-FREE, THAT DEFECTS WILL BE
+CORRECTED, OR THAT THE GAME OR THE SERVICE ARE FREE OF VIRUSES OR OTHER HARMFUL
+COMPONENTS. S2 EXPRESSLY DISCLAIMS ALL WARRANTIES, EXPRESS OR IMPLIED, INCLUDING
+WITHOUT LIMITATION THE WARRANTIES OF MERCHANTABILITY OR FITNESS FOR ANY
+PARTICULAR PURPOSE OR USE, AND NON-INFRINGEMENT.
+
+8. Limitation of Liability.
+
+NEITHER S2 NOR ITS SUBSIDIARIES, LICENSORS OR AFFILIATES SHALL BE LIABLE IN ANY
+WAY FOR DAMAGE OR LOSS OF ANY KIND RESULTING FROM (A) THE USE OF OR INABILITY TO
+USE THE GAME OR SERVICE INCLUDING WITHOUT LIMITATION LOSS OF GOODWILL, WORK
+STOPPAGE, COMPUTER FAILURE OR MALFUNCTION; (B) THE LOSS OR DAMAGE TO CHARACTERS,
+ACCOUNTS, STATISTICS, INVENTORIES OR USER PROFILE INFORMATION;
+OR (C)INTERRUPTIONS OF SERVICE INCLUDING WITHOUT LIMITATION ISP DISRUPTIONS,
+SOFTWARE OR HARDWARE FAILURES OR ANY OTHER EVENT WHICH MAY RESULT IN A LOSS OF
+DATA OR DISRUPTION OF SERVICE. IN NO EVENT WILL S2 BE LIABLE TO YOU OR ANYONE
+ELSE FOR ANY INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY OR CONSEQUENTIAL DAMAGES.
+
+9. Indemnification
+
+Upon request by S2, you agree to defend, indemnify and hold harmless S2 and its
+affiliates, subsidiaries, employees, contractors, officers, directors, vendors,
+and content providers from all liabilities, claims and expenses, including
+attorneys' fees, that arise from a breach of these Terms of Service for which
+you are responsible or in connection with your transmission of any Content on
+S2. S2 reserves the right, at its own expense, to assume the exclusive defense
+and control of any matter otherwise subject to indemnification by you. In that
+event, you shall have no further obligation to provide indemnification to S2 in
+that matter. This Section shall survive termination of this Agreement.
+
+10. Ownership of Materials
+
+All title, ownership rights and intellectual property rights in and to the Game
+and all copies thereof (including without limitation any titles, computer code,
+themes, objects, characters, character names, stories, dialog, catch phrases,
+locations, concepts, artwork, character inventories, structural or landscape
+designs, animations, sounds, musical compositions and recordings, audio-visual
+effects, storylines, character likenesses, methods of operation, moral rights,
+and any related documentation) are owned or licensed by S2. The Game is
+protected by the copyright laws of the United States, international treaties and
+conventions, and other laws. The Game may contain materials licensed by third
+parties, and the licensors of those materials may enforce their rights in the
+event of any violation of this License Agreement. In addition any and all
+properties created by end users or third-parties become property of S2. Any
+attempt to turn user created properties into commercial properties is expressly
+forbidden and will result in ex parte injunctive relief without bond to prevent
+the breach or threatened breach of intellectual property rights.
+
+11. Termination.
+
+This Agreement is effective until terminated. You may terminate this Agreement
+by terminating the Account and deleting the Game. In the event that you
+terminate or breach this Agreement, you will forfeit your right to any and all
+payments you may have made for game access to HoN. You agree and acknowledge
+that you are not entitled to any refund for any amounts which were paid on
+behalf of the Account prior to any termination of this Agreement. S2 may
+terminate this Agreement with or without notice by terminating the Account for
+violations of any provision of this Terms of Service Agreement. The provisions
+of this Agreement relating to ownership of the Game and all related activities,
+content, choice of law, indemnification and confidentiality shall survive any
+termination of this Agreement.
+
+12. Refunds
+
+No refunds will be provided that are requested more than 30 days after original
+purchase date. During open beta and retail launch you may request a refund
+within 30 days of purchase and a refund will be granted only if you DID NOT
+login and access the game client.
+
+13. Governing Law.
+
+Except as expressly provided otherwise, this Agreement shall be governed by,
+and will be construed under, the Laws of the United States of America and the
+law of the State of Michigan, without regard to choice of law principles. The
+application of the United Nations Convention on Contracts for the International
+Sale of Goods is expressly excluded. This Agreement shall be interpreted to give
+maximum effect to the terms and conditions hereof. Those who choose to access
+the Service from locations outside of the United States, do so on their own
+initiative contrary to the terms of this Agreement, and are responsible for
+compliance with local laws if and to the extent local laws are applicable.
+
+14. Miscellaneous.
+
+If any provision of this Agreement shall be unlawful, void, or for any reason
+unenforceable, then that provision shall be deemed severable from this Agreement
+and shall not affect the validity and enforceability of any remaining
+provisions. This Terms of Service Agreement is the complete and exclusive
+statement of the agreement between you and S2 concerning the Service, and this
+Agreement supersedes any prior or contemporaneous agreement, either oral or
+written, and any other communications with regard thereto between you and S2.
+This Agreement may only be modified as set forth herein. The section headings
+used herein are for reference only and shall not be read to have any legal
+effect.
+
+I HEREBY ACKNOWLEDGE THAT I HAVE READ AND UNDERSTAND THE FOREGOING TERMS OF
+SERVICE AGREEMENT AND AGREE THAT MY USE OF THE GAME AND THE SERVICE IS AN
+ACKNOWLEDGMENT OF MY AGREEMENT TO BE BOUND BY THE TERMS AND CONDITIONS OF THIS
+TERMS OF SERVICE AGREEMENT.