summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkaptoxic2017-02-05 00:14:19 -0500
committerkaptoxic2017-02-05 00:14:19 -0500
commitbb96d5e591af403126aede0e2f3bcbb36c5efc24 (patch)
tree6729ed854f3ec0ecaf8e383a6f567bb780f2d20e
parent4040089a1c4abfb8d6259cfe7693412328b64bc2 (diff)
downloadaur-bb96d5e591af403126aede0e2f3bcbb36c5efc24.tar.gz
Move the warning message to pre_install
-rw-r--r--PKGBUILD22
-rw-r--r--hon.install15
2 files changed, 16 insertions, 21 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ac3a4db63abc..2335f44a1269 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -26,27 +26,7 @@ md5sums=('25fb5ab8c49be0f1269c79520ccee789'
'dd2c8cd0f5bcafa25cfb583a92e21aec'
'd03e975286ae270d6bb77ae88b6ed3b4')
-package() {
- ## Thx to messo8080 for reminding us about the /tmp dir,
- ## on new installs this dir is in ram by default.
-
- if `pwd | grep -q "/tmp"`; then
- echo \
-"You are trying to build this pkg in /tmp dir.
-This is not so good idea as /tmp dir is in RAM
-by default. If you know that you have lots of
-ram (>8G) and swap and want to continue building in
-the current directory write yes and press ENTER.
-Otherwise write no and press ENTER. (You might
-consider changing the temporary directory, e.g.
-using --tmp for yaourt.)
-Continue?"
- read answer
- if [ "${answer}" == "no" ]; then
- false
- fi
- fi
-
+package() {
#mv HoNClient-${pkgver}-${pkgrel}.sh HoNClient-${pkgver}.sh
# Create Destination Directory
diff --git a/hon.install b/hon.install
index 234fa5c21f35..0bba874370cc 100644
--- a/hon.install
+++ b/hon.install
@@ -1,3 +1,18 @@
+pre_install() {
+ ## Thx to messo8080 for reminding us about the /tmp dir,
+ ## on new installs this dir is in ram by default.
+
+ if `pwd | grep -q "/tmp"`; then
+ echo \
+"You are trying to build this pkg in /tmp dir.
+This is not so good idea as /tmp dir is in RAM
+by default. Proceed if you know that you have lots of
+ram (>8G) and swap and want to continue building in
+the current directory. (Note that you might
+consider changing the temporary directory, e.g.
+using --tmp for yaourt.)"
+ fi
+}
post_install() {
echo ">>> You must read and agree to the terms in the EULAs found"