summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnthony Cozamanis2015-11-03 09:02:52 +0800
committerAnthony Cozamanis2015-11-03 09:02:52 +0800
commit130fb9ef8e39fbe1a06df64e7dc84b4935f04c0a (patch)
tree777ddff27fa2537a15ce6dffa695241527da0993
parent28daca90f7ef4d0af4c3129e51cf12e8169f5c48 (diff)
downloadaur-honeyd.tar.gz
Fixed, final
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD75
-rw-r--r--python.patch12
3 files changed, 67 insertions, 41 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e21975dbaeac..dc80ee331009 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,26 @@
pkgbase = honeyd
pkgdesc = A small daemon that creates virtual hosts on a network.
- pkgver = 1.5c
- pkgrel = 5
- url = http://www.honeyd.org
+ pkgver = 1.6.7
+ pkgrel = 8
+ url = https://github.com/DataSoft/Honeyd/
arch = i686
arch = x86_64
- arch = arm
+ arch = armv6h
+ arch = armv7h
license = GPL
depends = libdnet
depends = libevent
+ depends = libedit
depends = libpcap
- source = http://www.honeyd.org/uploads/honeyd-1.5c.tar.gz
- md5sums = 9887b44333e380a2205f64fa245cb727
+ depends = pcre
+ depends = zlib
+ depends = tcl
+ depends = python2
+ options = !makeflags
+ source = https://github.com/DataSoft/Honeyd/archive/honeyd-1.6.7.tar.gz
+ source = python.patch
+ sha1sums = a036409d59e92c0903b41ba4e8392aed499f6867
+ sha1sums = 85a76a6b8e05f22a243f62774343ed0a08ceb157
pkgname = honeyd
diff --git a/PKGBUILD b/PKGBUILD
index 58f453147795..d060d256b5d9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,46 @@
-# Maintainer: Anthony C <kurodroid.1@gmail.com>
-# Contributor: Michael P <ptchinster@archlinux.us>
-
-pkgname=honeyd
-pkgver=1.5c
-pkgrel=5
-pkgdesc="A small daemon that creates virtual hosts on a network."
-depends=('libdnet' 'libevent' 'libpcap')
-source=(http://www.honeyd.org/uploads/$pkgname-$pkgver.tar.gz)
-md5sums=('9887b44333e380a2205f64fa245cb727')
-arch=(i686 x86_64 arm)
-url="http://www.honeyd.org"
-license=("GPL")
-
-build()
-{
- cd "$srcdir/$pkgname-$pkgver"
- ./configure --prefix=/usr
- make
-}
+# This file is part of BlackArch Linux ( http://blackarch.org ).
+# See COPYING for license details.
+
+# TODO: check license
+pkgname='honeyd'
+pkgver='1.6.7'
+pkgrel=8
+pkgdesc='A small daemon that creates virtual hosts on a network.'
+url='https://github.com/DataSoft/Honeyd/'
+arch=('i686' 'x86_64' 'armv6h' 'armv7h')
+license=('GPL')
+depends=('libdnet' 'libevent' 'libedit' 'libpcap' 'pcre' 'zlib' 'tcl' 'python2')
+options=('!makeflags')
+source=("https://github.com/DataSoft/Honeyd/archive/honeyd-${pkgver}.tar.gz"
+ 'python.patch')
+sha1sums=('a036409d59e92c0903b41ba4e8392aed499f6867'
+ '85a76a6b8e05f22a243f62774343ed0a08ceb157')
+
+build() {
+ cd "$srcdir/Honeyd-honeyd-$pkgver"
+
+ ./autogen.sh
-check() {
- cd "$srcdir/$pkgname-$pkgver"
- make -k check
+ ./configure --prefix=/usr
+
+ #patch -p1 -i ../python.patch
+
+ make
+
+ sed -i 's/python/python2/' Makefile
}
-package()
-{
- mkdir -p $pkgdir/usr/share/honeyd
+package() {
+ cd "$srcdir/Honeyd-honeyd-$pkgver"
+
+ mkdir -p "$pkgdir/usr/share/honeyd"
- cd "$srcdir/$pkgname-$pkgver"
- #make prefix=$pkgdir/usr install
- make DESTDIR="$pkgdir/usr" install
+ make prefix="$pkgdir/usr" install
- # Fix permissions on webserver dirs
- for dir in webserver webserver/htdocs webserver/htdocs/graphs \
- webserver/htdocs/images webserver/htdocs/styles webserver/htdocs/templates \
- webserver/htdocs/templates/inc
- do chmod 755 $pkgdir/usr/share/honeyd/$dir
- done
+ for dir in webserver webserver/htdocs webserver/htdocs/graphs \
+ webserver/htdocs/images webserver/htdocs/styles \
+ webserver/htdocs/templates webserver/htdocs/templates/inc
+ do
+ chmod 755 "$pkgdir/usr/share/honeyd/$dir"
+ done
}
diff --git a/python.patch b/python.patch
new file mode 100644
index 000000000000..a6635ce9e4a6
--- /dev/null
+++ b/python.patch
@@ -0,0 +1,12 @@
+diff -rupN Honeyd-honeyd-1.6.7.orig/Makefile Honeyd-honeyd-1.6.7/Makefile
+--- Honeyd-honeyd-1.6.7.orig/Makefile 2013-11-16 19:09:13.467618562 -0500
++++ Honeyd-honeyd-1.6.7/Makefile 2013-11-16 19:09:57.180952740 -0500
+@@ -426,7 +426,7 @@ PACKAGE_STRING =
+ PACKAGE_TARNAME =
+ PACKAGE_URL =
+ PACKAGE_VERSION =
+-PATH_PYTHON = /usr/bin/python
++PATH_PYTHON = $(which python2)
+ PATH_PYTHON24 =
+ PATH_RRDTOOL =
+ PATH_SEPARATOR = :