summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxstraok2023-04-16 22:44:18 -0400
committerxstraok2023-04-16 22:44:18 -0400
commitb4cc8d0ebda9e35c7e5ca816b98a5f8935e55333 (patch)
tree4535012ec1b3f20f1750bbd7e4fb23123b7cd992
downloadaur-b4cc8d0ebda9e35c7e5ca816b98a5f8935e55333.tar.gz
initial release
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD74
-rw-r--r--honkers-launcher.desktop8
-rw-r--r--icon.pngbin0 -> 264714 bytes
4 files changed, 112 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..23e7bd9d84ba
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = honkers-launcher-git
+ pkgdesc = A launcher for a specific anime game with auto-patching, discord rpc and time tracking
+ pkgver = 1.0.0.r1.g80fb522
+ pkgrel = 1
+ url = https://github.com/an-anime-team/honkers-launcher
+ arch = x86_64
+ license = GPL3
+ makedepends = rust
+ depends = libadwaita
+ depends = tar
+ depends = unzip
+ depends = xdelta3
+ depends = cabextract
+ depends = git
+ depends = iputils
+ depends = gtk4
+ depends = glibc
+ optdepends = mangohud: FPS Hud/GUI
+ optdepends = gamemode: Game Optimizations
+ optdepends = gamescope: a tool from Valve that allows for games to run in an isolated Xwayland instance
+ provides = honkers-launcher
+ conflicts = honkers-launcher-bin
+ source = git+https://github.com/an-anime-team/honkers-launcher
+ source = icon.png
+ source = honkers-launcher.desktop
+ md5sums = SKIP
+ md5sums = 26b637e96d0f4382c8b132656a9ce3a5
+ md5sums = 739854fbecc047beb55d738dbdfe85d9
+
+pkgname = honkers-launcher-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4bd7a955100f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,74 @@
+# Maintainer: Maxim Korotkov <maximkorotkov4@gmail.com>
+
+pkgname=honkers-launcher-git
+_pkgname="${pkgname%-git}"
+pkgver=1.0.0.r1.g80fb522
+pkgrel=1
+pkgdesc="A launcher for a specific anime game with auto-patching, discord rpc and time tracking"
+url="https://github.com/an-anime-team/honkers-launcher"
+provides=("honkers-launcher")
+conflicts=("honkers-launcher-bin")
+arch=("x86_64")
+license=("GPL3")
+
+pkgver(){
+ cd "$_pkgname"
+ git describe --long --tags --abbrev=7 | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+depends=(
+ "libadwaita"
+ "tar"
+ "unzip"
+ "xdelta3"
+ "cabextract"
+ "git"
+ "iputils"
+ "gtk4"
+ "glibc"
+)
+
+makedepends=(rust)
+
+optdepends=(
+ "mangohud: FPS Hud/GUI"
+ "gamemode: Game Optimizations"
+ "gamescope: a tool from Valve that allows for games to run in an isolated Xwayland instance"
+)
+
+source=(
+ "git+https://github.com/an-anime-team/honkers-launcher"
+ "icon.png"
+ "honkers-launcher.desktop"
+)
+
+md5sums=(
+ SKIP
+ '26b637e96d0f4382c8b132656a9ce3a5'
+ '739854fbecc047beb55d738dbdfe85d9'
+)
+
+prepare() {
+ cd $_pkgname
+ git switch next
+ git submodule update --init --recursive --single-branch
+}
+
+build() {
+ cd $_pkgname
+ cargo build --release
+}
+
+package() {
+ cd $_pkgname
+
+ install -dm755 "${pkgdir}/usr/lib/${pkgname}"
+ install -dm755 "${pkgdir}/usr/bin/"
+ cp target/release/honkers-launcher "${pkgdir}/usr/lib/${pkgname}/honkers-launcher"
+
+ install -Dm644 "${srcdir}/icon.png" "${pkgdir}/usr/share/pixmaps/honkers-launcher.png"
+ ln -s "/usr/lib/${pkgname}/honkers-launcher" "${pkgdir}/usr/bin/honkers-launcher"
+ install -Dm644 "${srcdir}/honkers-launcher.desktop" -t "${pkgdir}/usr/share/applications"
+ install -Dm644 "${srcdir}/icon.png" "${pkgdir}/usr/share/icons/moe.launcher.honkers-launcher.png"
+}
+
diff --git a/honkers-launcher.desktop b/honkers-launcher.desktop
new file mode 100644
index 000000000000..9aaefabed783
--- /dev/null
+++ b/honkers-launcher.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=Honkers Launcher
+Comment=An Launcher for a specific anime game with auto-patching, discord rpc and time tracking
+Icon=honkers-launcher
+Exec=/usr/bin/honkers-launcher
+Type=Application
+Categories=Game
+Terminal=false
diff --git a/icon.png b/icon.png
new file mode 100644
index 000000000000..5fb586466f70
--- /dev/null
+++ b/icon.png
Binary files differ