summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2019-09-08 18:33:49 +0200
committerhaawda2019-09-08 18:33:49 +0200
commitad69222bb3a4bef6efb1ff077332035bdbfbe94f (patch)
treea0bd67934284b1c88736f09cc207ca13d95b3b5e
parentda50e583e3ce699a7c810ed52f91bb2b9a3aba0a (diff)
downloadaur-ad69222bb3a4bef6efb1ff077332035bdbfbe94f.tar.gz
fix build with bigloo not providing statical libs
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD14
2 files changed, 8 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8bb3bbe5ce76..8cfb84245905 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,10 @@
pkgbase = hop
pkgdesc = Software Development Kit for the Web
pkgver = 3.1.0
- pkgrel = 3
+ pkgrel = 4
epoch = 1
url = http://hop.inria.fr
install = hop.install
- arch = i686
arch = x86_64
license = GPL
license = LGPL
diff --git a/PKGBUILD b/PKGBUILD
index a3dfd931c43b..95e39afe94ec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,9 +5,9 @@
pkgname=hop
epoch=1
pkgver=3.1.0
-pkgrel=3
+pkgrel=4
pkgdesc="Software Development Kit for the Web"
-arch=('i686' 'x86_64')
+arch=('x86_64')
license=('GPL' 'LGPL')
depends=('bigloo' 'gmp' 'libunistring' 'libuv' 'avahi' 'sqlite')
makedepends=('git')
@@ -22,10 +22,10 @@ options=('!makeflags')
build() {
cd $pkgname
./configure --prefix=/usr --etcdir=/etc/hop --mandir=/usr/share/man \
- --disable-ssl --bigloobindir=/usr/bin \
- --bigloolibdir=/usr/lib/bigloo/4.3f
- make
- make doc
+ --disable-ssl --bigloobindir=/usr/bin --link=dynamic \
+ --bigloolibdir=/usr/lib/bigloo/4.3e
+ sed -i 's/, -static-all-bigloo//' share/Makefile
+ LD_LIBRARY_PATH="$PWD/lib/hop/3.1.0/" make
}
check() {
@@ -44,5 +44,5 @@ package() {
"$pkgdir"/usr/lib/systemd/system/hop.socket
install -Dm755 arch/archlinux/bin/hop.sh "$pkgdir"/usr/bin/hop.sh
- cd "$pkgdir"/usr/bin; rm hop; ln -s hop-3.0.0 hop
+ cd "$pkgdir"/usr/bin; rm hop; ln -s hop-3.1.0 hop
}