summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathon Fernyhough2020-12-17 22:09:07 +0000
committerJonathon Fernyhough2020-12-17 22:09:07 +0000
commit4d09d1941db3e08c3dc0fa7c740ea51db326ed56 (patch)
treee9e87e991260ec3ba8ed96b47e2172c5db7b5e22
parentb82184bf42eaa734469fc3fa3d89f4c7ad5754f1 (diff)
downloadaur-4d09d1941db3e08c3dc0fa7c740ea51db326ed56.tar.gz
Maybe commit the files this time...
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9ed952deadbe..a08a68a90b66 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -10,6 +10,7 @@ pkgbase = hopper
depends = libbsd
depends = python2
depends = qt5-base
+ depends = ncurses
provides = hopperv4
conflicts = hopperv4
source = https://d2ap6ypl1xbe4k.cloudfront.net/Hopper-v4-4.7.0-Linux.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
index b7f923d5c2b8..dfc933a8df0e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# Maintainer: Jonathon Fernyhough <jonathon_at_manjaro_org>
+# Maintainer: Jonathon Fernyhough <jonathon_at_m2x.dev>
pkgname=hopper
_pkgname=hopperv4
@@ -8,7 +8,7 @@ pkgdesc="Reverse engineering tool that lets you disassemble, decompile and debug
arch=(x86_64)
url="https://www.hopperapp.com/"
license=('Commercial')
-depends=('hicolor-icon-theme' 'libbsd' 'python2' 'qt5-base')
+depends=('hicolor-icon-theme' 'libbsd' 'python2' 'qt5-base' 'ncurses')
provides=("${_pkgname}")
conflicts=("${_pkgname}")
source=("https://d2ap6ypl1xbe4k.cloudfront.net/Hopper-v4-${pkgver}-Linux.pkg.tar.xz"
@@ -32,4 +32,10 @@ package() {
# Install license file
# https://www.hopperapp.com/license_agreement.html @ 2017-08-14
install -Dm644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+
+ # Temporary hacky fix for upstream packaging issue
+ cd ${pkgdir}/opt/hopper-v4/lib
+ ln -s /usr/lib/libformw.so.6 libform.so.6
+ ln -s /usr/lib/libncursesw.so.6 libncurses.so.6
+ ln -s /usr/lib/libtinfo.so.6 libtinfo.so.6
}