summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathon Fernyhough2018-11-22 00:20:35 +0000
committerJonathon Fernyhough2018-11-22 00:20:35 +0000
commit545f5d7568d6471019c8e48aac09df1156efdb2a (patch)
treedce76eaecec779b94d8dd156894b4a956f3de2e4
parenta7d7f8db30831cf5e75b7877c010cbbc3e083305 (diff)
downloadaur-545f5d7568d6471019c8e48aac09df1156efdb2a.tar.gz
hopper-4.4.8-1
[upstream] * Fixes a decompilation issue where a function call may disappear when used in an empty if / else statement * Fixes an issue with the pseudo-code view after a rebase operation * Initial support for 8 and 16 bits CPUs (but Intel 16 bits is NOT yet supported) * Initial support for MOS 6502 / 6510 CPU * Initial support for C64 PRG files, and D64 disk images [Jonathon Fernyhough] * Tidy PKGBUILD formatting a little
-rw-r--r--.SRCINFO6
-rw-r--r--ChangeLog8
-rw-r--r--PKGBUILD18
3 files changed, 20 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d1e0beb10015..abbf33c32a1c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = hopper
pkgdesc = Reverse engineering tool that lets you disassemble, decompile and debug your applications
- pkgver = 4.4.6
+ pkgver = 4.4.8
pkgrel = 1
url = https://www.hopperapp.com/
changelog = ChangeLog
@@ -12,9 +12,9 @@ pkgbase = hopper
depends = qt5-base
provides = hopperv4
conflicts = hopperv4
- source = https://d2ap6ypl1xbe4k.cloudfront.net/Hopper-v4-4.4.6-Linux.pkg.tar.xz
+ source = https://d2ap6ypl1xbe4k.cloudfront.net/Hopper-v4-4.4.8-Linux.pkg.tar.xz
source = LICENSE
- sha1sums = 11acba0ed439feddbb5cc30091b9c98d1110c7d0
+ sha1sums = ef4c1e82ecbb80f88cf5507921bc3d86a76002df
sha1sums = c3f410d29524eb02a8bf3dc1b29aaeb82b1844e6
pkgname = hopper
diff --git a/ChangeLog b/ChangeLog
index e453103aa3d4..4598459346d9 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,11 @@
+4.4.8 (2018-11-21 15:07:41)
+
+ Fixes a decompilation issue where a function call may disappear when used in an empty if / else statement,
+ Fixes an issue with the pseudo-code view after a rebase operation,
+ Initial support for 8 and 16 bits CPUs (but Intel 16 bits is NOT yet supported),
+ Initial support for MOS 6502 / 6510 CPU,
+ Initial support for C64 PRG files, and D64 disk images.
+
4.4.7 (2018-11-13 21:09:39)
Fixes an issue on some systems with empty windows.
diff --git a/PKGBUILD b/PKGBUILD
index d7d573220794..c320c65b0300 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,21 @@
# Maintainer: Jonathon Fernyhough <jonathon_at_manjaro_org>
-pkgname='hopper'
-_pkgname='hopperv4'
-pkgver='4.4.6'
-pkgrel='1'
-pkgdesc='Reverse engineering tool that lets you disassemble, decompile and debug your applications'
-arch=('x86_64')
-url='https://www.hopperapp.com/'
+pkgname=hopper
+_pkgname=hopperv4
+pkgver=4.4.8
+pkgrel=1
+pkgdesc="Reverse engineering tool that lets you disassemble, decompile and debug your applications"
+arch=(x86_64)
+url="https://www.hopperapp.com/"
license=('Commercial')
depends=('hicolor-icon-theme' 'libbsd' 'python2' 'qt5-base')
provides=("${_pkgname}")
conflicts=("${_pkgname}")
source=("https://d2ap6ypl1xbe4k.cloudfront.net/Hopper-v4-${pkgver}-Linux.pkg.tar.xz"
'LICENSE')
-sha1sums=('11acba0ed439feddbb5cc30091b9c98d1110c7d0'
+sha1sums=('ef4c1e82ecbb80f88cf5507921bc3d86a76002df'
'c3f410d29524eb02a8bf3dc1b29aaeb82b1844e6')
-changelog='ChangeLog'
+changelog=ChangeLog
package() {
# Copy package content