summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathon Fernyhough2020-12-17 21:45:46 +0000
committerJonathon Fernyhough2020-12-17 22:07:49 +0000
commitb82184bf42eaa734469fc3fa3d89f4c7ad5754f1 (patch)
tree6bcf2d98a0659d88505acd4a77218bd7848d0108
parent7453497bd04c4b969cac0124a70fde5f52aeab13 (diff)
downloadaur-b82184bf42eaa734469fc3fa3d89f4c7ad5754f1.tar.gz
Upstream 4.7.0. Hack around upstream packaging issue.
-rw-r--r--.SRCINFO6
-rw-r--r--ChangeLog26
-rw-r--r--PKGBUILD4
3 files changed, 31 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 98d420127423..9ed952deadbe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = hopper
pkgdesc = Reverse engineering tool that lets you disassemble, decompile and debug your applications
- pkgver = 4.5.29
+ pkgver = 4.7.0
pkgrel = 1
url = https://www.hopperapp.com/
changelog = ChangeLog
@@ -12,9 +12,9 @@ pkgbase = hopper
depends = qt5-base
provides = hopperv4
conflicts = hopperv4
- source = https://d2ap6ypl1xbe4k.cloudfront.net/Hopper-v4-4.5.29-Linux.pkg.tar.xz
+ source = https://d2ap6ypl1xbe4k.cloudfront.net/Hopper-v4-4.7.0-Linux.pkg.tar.xz
source = LICENSE
- sha1sums = 485007e224c271552594c25f82379497b4589d0f
+ sha1sums = 9b8a0e08b89ae9efaf43ac6f00bd18bc5920458d
sha1sums = c3f410d29524eb02a8bf3dc1b29aaeb82b1844e6
pkgname = hopper
diff --git a/ChangeLog b/ChangeLog
index 1521437d1cfa..1161980579bc 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,29 @@
+4.7.0 (2020-12-14 16:15:48)
+
+ Fixes some ARMv8.1 instructions.
+
+4.6.3 (2020-12-01 17:10:33)
+
+ Fixes a crash for some elements of the DYLD cache of iOS 14.
+
+4.6.2 (2020-11-12 14:45:10)
+
+ Fixes the debugger which was unable to launch some old binaries.
+
+4.6.1 (2020-11-04 15:59:24)
+
+ Fixes a crash in the decompiler when rewriting conditional expressions.
+
+4.6.0 (2020-11-03 16:15:07)
+
+ First Apple Silicon release,
+ Support for AArch64 debugger,
+ Support for macOS Big Sur,
+ Improves Objective-C metadata parsing,
+ Improves DYLD Shared Cache parsing,
+ Adds an option to deal with PAC pointers on Apple Silicon binaries,
+ Many improvements and fixes.
+
4.5.29 (2020-06-19 14:13:13)
Fixes an issue when compiling the SDK examples with the latest Xcode,
diff --git a/PKGBUILD b/PKGBUILD
index 105c99210c8d..b7f923d5c2b8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=hopper
_pkgname=hopperv4
-pkgver=4.5.29
+pkgver=4.7.0
pkgrel=1
pkgdesc="Reverse engineering tool that lets you disassemble, decompile and debug your applications"
arch=(x86_64)
@@ -13,7 +13,7 @@ provides=("${_pkgname}")
conflicts=("${_pkgname}")
source=("https://d2ap6ypl1xbe4k.cloudfront.net/Hopper-v4-${pkgver}-Linux.pkg.tar.xz"
'LICENSE')
-sha1sums=('485007e224c271552594c25f82379497b4589d0f'
+sha1sums=('9b8a0e08b89ae9efaf43ac6f00bd18bc5920458d'
'c3f410d29524eb02a8bf3dc1b29aaeb82b1844e6')
changelog=ChangeLog