summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathon Fernyhough2018-10-10 21:31:10 +0100
committerJonathon Fernyhough2018-10-10 21:31:10 +0100
commitff6ee6a7fe2befc2cee9a88612a8c7c071c1512b (patch)
tree69a9ede09b5b59a0dd0562310ba8feb3f1852038
parente5356b07448526a0289e88b9bd5a5be91912814b (diff)
downloadaur-ff6ee6a7fe2befc2cee9a88612a8c7c071c1512b.tar.gz
hopper-4.4.4-1
[upstream] * Fixes a crash on disassembling files written in Go * Fixes the debugger for 32bits executables
-rw-r--r--.SRCINFO6
-rw-r--r--ChangeLog15
-rw-r--r--PKGBUILD4
3 files changed, 20 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 393283265566..61bd44eb1cf7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = hopper
pkgdesc = Reverse engineering tool that lets you disassemble, decompile and debug your applications
- pkgver = 4.4.1
+ pkgver = 4.4.4
pkgrel = 1
url = https://www.hopperapp.com/
changelog = ChangeLog
@@ -12,9 +12,9 @@ pkgbase = hopper
depends = qt5-base
provides = hopperv4
conflicts = hopperv4
- source = https://d2ap6ypl1xbe4k.cloudfront.net/Hopper-v4-4.4.1-Linux.pkg.tar.xz
+ source = https://d2ap6ypl1xbe4k.cloudfront.net/Hopper-v4-4.4.4-Linux.pkg.tar.xz
source = LICENSE
- sha1sums = 76328ff3c8e8502caa30628ded86860e538b588b
+ sha1sums = 5a62bdb752813f7119d59fe5d034ad8e381a2889
sha1sums = c3f410d29524eb02a8bf3dc1b29aaeb82b1844e6
pkgname = hopper
diff --git a/ChangeLog b/ChangeLog
index ab739a6fa33a..089159db45c4 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,18 @@
+4.4.4 (2018-10-10 14:37:28)
+
+ Fixes a crash on disassembling files written in Go,
+ Fixes the debugger for 32bits executables.
+
+4.4.3 (2018-10-09 17:42:34)
+
+ Fixes small graphical issues,
+ Added a way to choose between the light or dark interface independently from the system settings,
+ Fixes an issue in the debugger preventing from attaching to the Finder or the Dock.
+
+4.4.2 (2018-10-04 19:41:07)
+
+ Fixes drawing issues introduced in 4.4.0.
+
4.4.1 (2018-10-03 19:28:51)
Implements most of the ARMv8.1, ARMv8.2 and ARMv8.3 extensions.
diff --git a/PKGBUILD b/PKGBUILD
index d08cd3c3eae0..db1235a75bc1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname='hopper'
_pkgname='hopperv4'
-pkgver='4.4.1'
+pkgver='4.4.4'
pkgrel='1'
pkgdesc='Reverse engineering tool that lets you disassemble, decompile and debug your applications'
arch=('x86_64')
@@ -13,7 +13,7 @@ provides=("${_pkgname}")
conflicts=("${_pkgname}")
source=("https://d2ap6ypl1xbe4k.cloudfront.net/Hopper-v4-${pkgver}-Linux.pkg.tar.xz"
'LICENSE')
-sha1sums=('76328ff3c8e8502caa30628ded86860e538b588b'
+sha1sums=('5a62bdb752813f7119d59fe5d034ad8e381a2889'
'c3f410d29524eb02a8bf3dc1b29aaeb82b1844e6')
changelog='ChangeLog'