summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGowtham20032023-11-11 15:22:34 +0530
committerGowtham20032023-11-11 15:22:34 +0530
commitac326b866104ce4fcb6547eeb4b7628bda8396b7 (patch)
treeff798f1c605f62523e5b1eef98aaeeff4904dca9
downloadaur-ac326b866104ce4fcb6547eeb4b7628bda8396b7.tar.gz
Initial commit
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD23
-rw-r--r--hoppscotch-bin.install13
3 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..051ce3fce9b0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = hoppscotch-bin
+ pkgdesc = Hoppscotch. Open source API development ecosystem
+ pkgver = 23.8.3
+ pkgrel = 1
+ url = https://hoppscotch.io/
+ install = hoppscotch-bin.install
+ arch = x86_64
+ groups =
+ license = MIT
+ depends = cairo
+ depends = desktop-file-utils
+ depends = gdk-pixbuf2
+ depends = glib2
+ depends = gtk3
+ depends = hicolor-icon-theme
+ depends = libsoup
+ depends = openssl-1.1
+ depends = pango
+ depends = webkit2gtk
+ options = !strip
+ options = !emptydirs
+ source_x86_64 = https://github.com/hoppscotch/releases/releases/download/v23.8.3/Hoppscotch_linux_x64.AppImage
+ sha512sums_x86_64 = 9d217da38ae6d0ef7a87066720510ece355b353a1c3710435d381c41d7f84d6c6154e13cb7779c97df8b9aba7cd40e3534f1d2d51bc96e9ca2e22ec7eee249b0
+
+pkgname = hoppscotch-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8045a9126c55
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Generated by debtap
+# Maintainer: Gowtham2003 <gowtham2003g@gmail.com>
+# Contributor: Gowtham2003 <gowtham2003g@gmail.com>
+pkgname=hoppscotch-bin
+pkgver=23.8.3
+pkgrel=1
+pkgdesc="Hoppscotch. Open source API development ecosystem"
+arch=('x86_64')
+url="https://hoppscotch.io/"
+license=('MIT')
+groups=('')
+depends=('cairo' 'desktop-file-utils' 'gdk-pixbuf2' 'glib2' 'gtk3' 'hicolor-icon-theme' 'libsoup' 'openssl-1.1' 'pango' 'webkit2gtk')
+options=('!strip' '!emptydirs')
+install=${pkgname}.install
+source_x86_64=("https://github.com/hoppscotch/releases/releases/download/v${pkgver}-${pkgrel}/Hoppscotch_linux_x64.deb")
+sha512sums_x86_64=('9d217da38ae6d0ef7a87066720510ece355b353a1c3710435d381c41d7f84d6c6154e13cb7779c97df8b9aba7cd40e3534f1d2d51bc96e9ca2e22ec7eee249b0')
+
+package(){
+
+ # Extract package data
+ tar -xz -f data.tar.gz -C "${pkgdir}"
+
+}
diff --git a/hoppscotch-bin.install b/hoppscotch-bin.install
new file mode 100644
index 000000000000..b50ffb36e4a2
--- /dev/null
+++ b/hoppscotch-bin.install
@@ -0,0 +1,13 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+ update-desktop-database -q
+}