summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlphaJack2023-06-29 01:20:12 +0200
committerAlphaJack2023-06-29 01:20:12 +0200
commit48430b9bc88460f284d8472ff677d38958ba5ed5 (patch)
tree7f6a917eb9e42189ee42834f1ba255847a7df764
downloadaur-48430b9bc88460f284d8472ff677d38958ba5ed5.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD34
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..65ac3a585fb1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = horcrux-git
+ pkgdesc = Split your file into encrypted fragments so that you don't need to remember a passcode
+ pkgver = 0.3.r16.g6575949
+ pkgrel = 1
+ url = https://github.com/jesseduffield/horcrux
+ arch = x86_64
+ license = MIT
+ makedepends = go
+ options = !strip
+ source = git+https://github.com/jesseduffield/horcrux
+ sha256sums = SKIP
+
+pkgname = horcrux-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e5c207061ec2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: AlphaJack <alphajack at tuta dot io>
+
+pkgname="horcrux-git"
+pkgver=0.3.r16.g6575949
+pkgrel=1
+pkgdesc="Split your file into encrypted fragments so that you don't need to remember a passcode"
+arch=("x86_64")
+url="https://github.com/jesseduffield/horcrux"
+license=("MIT")
+makedepends=("go")
+source=("git+$url")
+sha256sums=("SKIP")
+options=("!strip")
+
+pkgver(){
+ cd "horcrux"
+ git describe --long --tags --abbrev=7 | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//g'
+}
+
+build(){
+ cd "horcrux"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+ go build -o horcrux .
+}
+
+package(){
+ cd "horcrux"
+ install -D -m 0755 "horcrux" "$pkgdir/usr/bin/horcrux"
+ install -D -m 0644 "LICENSE" "$pkgdir/usr/share/licenses/horcrux/LICENSE"
+}