summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLukas K2020-09-13 18:22:22 +0200
committerLukas K2020-09-13 18:22:22 +0200
commite717f1882e612545fd09fef856fe0df6b0d32474 (patch)
tree47ede913bd2b896ce33be6c4e74eed6b556a9769
parent1755da2f1890127cc6e78348ab6a56adf4960498 (diff)
downloadaur-e717f1882e612545fd09fef856fe0df6b0d32474.tar.gz
use make install and conflict with horizon-eda
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD17
2 files changed, 15 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4f4e1606eaaa..f5abff66f49e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,16 @@
# Generated by mksrcinfo v8
-# Tue Apr 16 19:14:57 UTC 2019
+# Sun Sep 13 16:21:51 UTC 2020
pkgbase = horizon-git
pkgdesc = free EDA package written in C++
- pkgver = r185.59b2f6b
- pkgrel = 2
- url = https://github.com/carrotIndustries/horizon
+ pkgver = r1811.cbf9df3a
+ pkgrel = 1
+ url = https://github.com/horizon-eda/horizon
arch = x86_64
arch = i686
license = GPL
makedepends = boost-libs
makedepends = boost
makedepends = glm
- depends = yaml-cpp
depends = zeromq
depends = gtkmm3
depends = cairomm
@@ -21,7 +20,9 @@ pkgbase = horizon-git
depends = curl
depends = opencascade
depends = podofo
- source = git+https://github.com/carrotIndustries/horizon.git
+ depends = libzip
+ conflicts = horizon-eda
+ source = git+https://github.com/horizon-eda/horizon.git
md5sums = SKIP
pkgname = horizon-git
diff --git a/PKGBUILD b/PKGBUILD
index 22559dac4186..bf8fcce8fc2d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,17 @@
_name=horizon
pkgname=${_name}-git
-pkgver=r185.59b2f6b
-pkgrel=2
+pkgver=r1811.cbf9df3a
+pkgrel=1
pkgdesc="free EDA package written in C++"
arch=('x86_64' 'i686')
-url="https://github.com/carrotIndustries/horizon"
+url="https://github.com/horizon-eda/horizon"
license=('GPL')
-depends=('yaml-cpp' 'zeromq' 'gtkmm3' 'cairomm' 'librsvg' 'sqlite3' 'libgit2' 'curl' 'opencascade' 'podofo')
+depends=('zeromq' 'gtkmm3' 'cairomm' 'librsvg' 'sqlite3' 'libgit2' 'curl' 'opencascade' 'podofo' 'libzip')
makedepends=('boost-libs' 'boost' 'glm')
-source=("git+https://github.com/carrotIndustries/horizon.git")
+source=("git+https://github.com/horizon-eda/horizon.git")
md5sums=('SKIP')
+conflicts=('horizon-eda')
pkgver() {
cd "$srcdir/$_name"
@@ -24,8 +25,6 @@ build() {
}
package() {
- for f in horizon-imp horizon-pool horizon-eda horizon-prj
- do
- install -Dm755 $srcdir/$_name/$f $pkgdir/usr/bin/$f
- done
+ cd "$srcdir/$_name"
+ make DESTDIR=$pkgdir PREFIX=/usr install
}