summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBuildTools2016-03-23 18:51:37 +0100
committerBuildTools2016-03-23 18:51:37 +0100
commit7c1b41e0969d93a2e3e1885da92191d0309b25e4 (patch)
treef2a3a347cff32f4d00fe3f89eea4f1ded4c685a9
downloadaur-7c1b41e0969d93a2e3e1885da92191d0309b25e4.tar.gz
Initial upload
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD51
2 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d0e446e53051
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = horizon-launcher-git
+ pkgdesc = A customizable, cross-platform and open-source launcher for launching all your games on Steam and other gaming services
+ pkgver = r739.ad2d3c6
+ pkgrel = 1
+ url = http://launchhorizon.com
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = cmake
+ makedepends = make
+ depends = qt5-base
+ depends = qt5-tools
+ depends = qt5-webkit
+ provides = horizon-launcher
+ source = horizon-launcher::git+https://github.com/horizonlauncher/client.git
+ md5sums = SKIP
+
+pkgname = horizon-launcher-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..34107e9c9fe2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: PureTryOut
+pkgname=horizon-launcher-git
+pkgver=r739.ad2d3c6
+pkgrel=1
+epoch=
+pkgdesc="A customizable, cross-platform and open-source launcher for launching all your games on Steam and other gaming services"
+arch=('x86_64')
+url="http://launchhorizon.com"
+license=('MIT')
+groups=()
+depends=('qt5-base' 'qt5-tools' 'qt5-webkit')
+makedepends=('git' 'cmake' 'make')
+checkdepends=()
+optdepends=()
+provides=('horizon-launcher')
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=('horizon-launcher::git+https://github.com/horizonlauncher/client.git')
+noextract=()
+md5sums=('SKIP')
+validpgpkeys=()
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$pkgname"
+
+ if [[ -d build ]]; then
+ rm -rf build
+ fi
+ mkdir build && cd build
+
+ cmake ..
+ make -j$(expr $(nproc) + 1) -l$(nproc)
+}
+
+
+package() {
+ cd "$pkgname"
+ install -Dm755 build/HorizonLauncher "$pkgdir/usr/bin/horizon-launcher"
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/"$pkgname"/LICENSE
+
+ cd .. && rm -rf build
+}