summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBuildTools2016-03-23 20:17:14 +0100
committerBuildTools2016-03-23 20:17:14 +0100
commitc1c7e5a3ed5ea6ff70e37b51d1a8521440e3510b (patch)
treedbbb165d2d71d620c715cf5c8edda1e3c08ad132
parent6465c3ed5c61d70f7cf27c969325a82c2c07ac65 (diff)
downloadaur-c1c7e5a3ed5ea6ff70e37b51d1a8521440e3510b.tar.gz
Added a .desktop file
-rw-r--r--PKGBUILD12
-rw-r--r--horizon-launcher.desktop9
2 files changed, 18 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dc58ccb6b270..4568c82fb243 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -19,9 +19,11 @@ backup=()
options=()
install=
changelog=
-source=('horizon-launcher-git::git+https://github.com/horizonlauncher/client.git')
+source=('horizon-launcher-git::git+https://github.com/horizonlauncher/client.git'
+ 'horizon-launcher.desktop')
noextract=()
-md5sums=('SKIP')
+sha256sums=('SKIP'
+ 'cfae40664d6fca23ae03721142f88bb3b65f0ebd5b7dd1fdb141ce91f9130d30')
validpgpkeys=()
pkgver() {
@@ -44,8 +46,12 @@ build() {
package() {
cd "$pkgname"
+
+ # The application
install -Dm755 build/HorizonLauncher "$pkgdir/usr/bin/horizon-launcher"
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/"$pkgname"/LICENSE
- cd .. && rm -rf build
+ # .desktop file and icon
+ install -Dm644 "$srcdir/horizon-launcher.desktop" "$pkgdir"/usr/share/applications/horizon-launcher.desktop
+ install -Dm644 Resource/Icons/Horizon_Icon.png "$pkgdir"/usr/share/icons/hicolor/256x256/apps/horizon-launcher.png
}
diff --git a/horizon-launcher.desktop b/horizon-launcher.desktop
new file mode 100644
index 000000000000..fb9990465d2c
--- /dev/null
+++ b/horizon-launcher.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Type=Application
+Version=1.0
+Name=Horizon Launcher
+Comment=A customizable, cross-platform and open-source launcher for launching all your games on Steam and other gaming services
+Exec=horizon-launcher
+Icon=horizon-launcher
+Terminal=false
+Categories=Game;