summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryochananmarqos2019-06-06 08:56:31 -0600
committeryochananmarqos2019-06-06 08:56:31 -0600
commit770d4867406795bcae4a05d2e3d339ece7a04bec (patch)
treef0621ca389cbb535bf94e854d683200e0b4c5770
downloadaur-770d4867406795bcae4a05d2e3d339ece7a04bec.tar.gz
initial upload
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD17
2 files changed, 31 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2cb3951aecd8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = horizontal-grub
+ pkgdesc = Transforms the current grub configuration file generated by grub(2) to a fake-horizontal style.
+ pkgver = 0.1.1
+ pkgrel = 1
+ url = https://github.com/petsam/horizontal-grub
+ arch = any
+ license = GPL3
+ depends = bash
+ depends = grub
+ optdepends = polkit: for saving the new configuration to system
+ source = horizontal-grub-0.1.1.tar.gz::https://github.com/petsam/horizontal-grub/archive/0.1.1.tar.gz
+
+pkgname = horizontal-grub
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..94126a7c1ee2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: Mark Wagie <yochanan dot marqos at gmail dot com>
+pkgname=horizontal-grub
+pkgver=0.1.1
+pkgrel=1
+pkgdesc="Transforms the current grub configuration file generated by grub(2) to a fake-horizontal style."
+arch=('any')
+url="https://github.com/petsam/horizontal-grub"
+license=('GPL3')
+depends=('bash' 'grub')
+optdepends=('polkit: for saving the new configuration to system')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/petsam/$pkgname/archive/$pkgver.tar.gz")
+sha256sums=()
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm755 horizontal-grub $pkgdir/usr/bin/horizontal-grub
+}