summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthew Charlston2023-01-13 06:11:46 +0000
committerMatthew Charlston2023-01-13 06:11:46 +0000
commit1693bc9af155a538a637039e42b3e6320824f8e5 (patch)
tree0ec4c070f9a840c3b9733cb366b0cb818fcec306
parentd1a5b4d213a29818df84aa4b46bcbb409ab8dd0e (diff)
downloadaur-1693bc9af155a538a637039e42b3e6320824f8e5.tar.gz
update to 1.0.2, add even more dependencies
-rw-r--r--.SRCINFO6
-rwxr-xr-xPKGBUILD10
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 387d6286438a..0099b145eeba 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,14 @@
pkgbase = horizontallyspinningrat
pkgdesc = The horizontally spinning rat - now on your desktop!
- pkgver = 1.0.1
- pkgrel = 2
+ pkgver = 1.0.2
+ pkgrel = 1
url = https://github.com/mcharlsto/rat
arch = x86_64
license = GPL3
depends = sox
depends = opusfile
+ depends = bash
+ depends = sharutils
source = https://github.com/mcharlsto/rat/releases/latest/download/rat
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 50bd4e79db05..b4b175440a93 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: Matthew Charlston <firstname _at_ mcharlsto dot uk>
pkgname="horizontallyspinningrat"
-pkgver=1.0.1
-pkgrel=2
-depends=("sox" "opusfile")
+pkgver=1.0.2
+pkgrel=1
+depends=("sox" "opusfile" "bash" "sharutils")
pkgdesc="The horizontally spinning rat - now on your desktop!"
url="https://github.com/mcharlsto/rat"
arch=("x86_64")
@@ -12,7 +12,5 @@ source=("https://github.com/mcharlsto/rat/releases/latest/download/rat")
sha256sums=("SKIP")
package() {
- chmod +x rat
- mkdir -p $pkgdir/usr/bin
- cp ./rat ${pkgdir}/usr/bin/rat
+ install -Dm755 rat -t "${pkgdir}/usr/bin/"
}