summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthew Charlston2023-12-27 00:55:12 +0000
committerMatthew Charlston2023-12-27 00:55:12 +0000
commit9528df6d007319f6ceb861b6c80202b3d09bc491 (patch)
tree04c76cbed4b6da307b152715c920d0cc97ba2324
parent597ff3c07a85918745a45023f7b3026cae2e4cff (diff)
downloadaur-9528df6d007319f6ceb861b6c80202b3d09bc491.tar.gz
update to 2.0
-rw-r--r--.SRCINFO10
-rwxr-xr-xPKGBUILD14
2 files changed, 11 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3ebaa49e1d41..e6a6dd9b14b1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,12 @@
pkgbase = horizontallyspinningrat
pkgdesc = The horizontally spinning rat - now on your desktop!
- pkgver = 1.1
+ pkgver = 2.0
pkgrel = 1
url = https://github.com/mcharlsto/rat
arch = x86_64
license = GPL3
- depends = sox
- depends = opusfile
- depends = bash
- depends = sharutils
optdepends = lolcat: rainbow mode
- source = https://github.com/mcharlsto/rat/releases/download/1.1/rat
- sha256sums = f77b2ca63bd714fa1c1853de085d405a8598c79848eef325b71f5243bc76e73e
+ source = https://github.com/mcharlsto/rat/archive/refs/tags/2.0.tar.gz
+ sha256sums = ec01924d55793617c49cf7043695d3b1b1dafd70b4f18aae33d1b566990ffabc
pkgname = horizontallyspinningrat
diff --git a/PKGBUILD b/PKGBUILD
index 5a4526433c36..b37621e2a503 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,19 @@
-# Maintainer: Matthew Charlston <firstname _at_ mcharlsto dot uk>
+# Maintainer: Matthew Charlston
pkgname="horizontallyspinningrat"
-pkgver=1.1
+pkgver=2.0
pkgrel=1
-depends=("sox" "opusfile" "bash" "sharutils")
+depends=()
optdepends=("lolcat: rainbow mode")
pkgdesc="The horizontally spinning rat - now on your desktop!"
url="https://github.com/mcharlsto/rat"
arch=("x86_64")
license=("GPL3")
-source=("https://github.com/mcharlsto/rat/releases/download/${pkgver}/rat")
-sha256sums=('f77b2ca63bd714fa1c1853de085d405a8598c79848eef325b71f5243bc76e73e')
+source=("https://github.com/mcharlsto/rat/archive/refs/tags/$pkgver.tar.gz")
+sha256sums=("ec01924d55793617c49cf7043695d3b1b1dafd70b4f18aae33d1b566990ffabc")
package() {
- install -Dm755 rat -t "${pkgdir}/usr/bin/"
+ cd $srcdir/rat-$pkgver
+ make linux_audio
+ install -Dm755 ./bin/rat -t "${pkgdir}/usr/bin/"
}