summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthew Charlston2023-01-12 18:58:17 +0000
committerMatthew Charlston2023-01-12 18:58:17 +0000
commitd767264b442c83d6932de89100fc45bfa420ac9a (patch)
tree9d09953e055410bad149cd42c840d0230f4ecaa8
downloadaur-d767264b442c83d6932de89100fc45bfa420ac9a.tar.gz
add pkgbuild
-rw-r--r--.SRCINFO11
-rwxr-xr-xPKGBUILD17
2 files changed, 28 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3ce552b81705
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,11 @@
+pkgbase = horizontallyspinningrat
+ pkgdesc = The horizontally spinning rat - now on your desktop!
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/mcharlsto/rat
+ arch = x86_64
+ license = GPL3
+ source = https://github.com/mcharlsto/rat/releases/latest/download/rat
+ sha256sums = SKIP
+
+pkgname = horizontallyspinningrat
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..d7a9f101d527
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: Matthew Charlston <firstname _at_ mcharlsto dot uk>
+
+pkgname="horizontallyspinningrat"
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="The horizontally spinning rat - now on your desktop!"
+url="https://github.com/mcharlsto/rat"
+arch=("x86_64")
+license=("GPL3")
+source=("https://github.com/mcharlsto/rat/releases/latest/download/rat")
+sha256sums=("SKIP")
+
+package() {
+ chmod +x rat
+ mkdir -p $pkgdir/usr/bin
+ cp ./rat ${pkgdir}/usr/bin/rat
+}