summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVedant K2021-07-07 17:14:48 +0530
committerVedant K2021-07-07 17:14:48 +0530
commit2de885daa906b4990125fd37f36630f4f8aeb8a1 (patch)
treefe04457b1ab2500927e260f5273151d494176c2d
downloadaur-2de885daa906b4990125fd37f36630f4f8aeb8a1.tar.gz
init: add hors to AUR; v0.8.2
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD24
3 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..aa38ade794ba
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = hors
+ pkgdesc = Instant coding answers via the command line (howdoi in rust)
+ pkgver = 0.8.2
+ pkgrel = 1
+ url = https://github.com/WindSoilder/hors
+ arch = x86_64
+ license = GPL3
+ makedepends = rust
+ makedepends = git
+ depends = gcc-libs
+ source = hors-0.8.2.tar.gz::https://github.com/WindSoilder/hors/archive/v0.8.2.tar.gz
+ sha256sums = 22419b26f64a2793759d3a3616df58196897cd9227074f475aeb3e1c366296a9
+
+pkgname = hors
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..21f86cae94ac
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg
+src
+*.tar* \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3064d4182592
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Vedant K <gamemaker0042 at gmail dot com>
+
+pkgname=hors
+pkgver=0.8.2
+pkgrel=1
+pkgdesc='Instant coding answers via the command line (howdoi in rust)'
+arch=('x86_64')
+url='https://github.com/WindSoilder/hors'
+license=('GPL3')
+depends=('gcc-libs')
+makedepends=('rust' 'git')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/WindSoilder/$pkgname/archive/v$pkgver.tar.gz")
+sha256sums=('22419b26f64a2793759d3a3616df58196897cd9227074f475aeb3e1c366296a9')
+
+build() {
+ cd "$pkgname-$pkgver"
+ cargo build --release --locked --all-features --target-dir=target
+ strip target/release/hors
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm755 "target/release/hors" "$pkgdir/usr/bin/hors"
+}