summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGaetan Bisson2015-08-27 12:01:19 -1000
committerGaetan Bisson2015-08-27 12:01:19 -1000
commitaea48a4e012dd951d812fa08de71296e4f205174 (patch)
tree8c9f7f31355c8405a769a9aac146621479e1feae
downloadaur-aea48a4e012dd951d812fa08de71296e4f205174.tar.gz
original commit
follow upstream closer than [community] package does
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD50
-rw-r--r--service10
3 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cb9b8c89dbd3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = hostapd-git
+ pkgdesc = IEEE 802.11 AP, IEEE 802.1X/WPA/WPA2/EAP/RADIUS Authenticator
+ pkgver = 20150824.20f331b
+ pkgrel = 1
+ url = http://w1.fi/hostapd/
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = git
+ depends = openssl
+ depends = libnl
+ provides = hostapd
+ conflicts = hostapd
+ options = emptydirs
+ source = git://w1.fi/hostap.git
+ source = service
+ sha1sums = SKIP
+ sha1sums = a8bc9ad3963001a53dedf6581f7be9750b1c3a73
+
+pkgname = hostapd-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f9e7d7618f49
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Maintainer: Gaetan Bisson <bisson@archlinux.org>
+
+pkgname=hostapd-git
+pkgver=20150824.20f331b
+pkgrel=1
+pkgdesc='IEEE 802.11 AP, IEEE 802.1X/WPA/WPA2/EAP/RADIUS Authenticator'
+url='http://w1.fi/hostapd/'
+arch=('i686' 'x86_64')
+license=('custom')
+makedepends=('git')
+depends=('openssl' 'libnl')
+source=('git://w1.fi/hostap.git'
+ 'service')
+sha1sums=('SKIP'
+ 'a8bc9ad3963001a53dedf6581f7be9750b1c3a73')
+
+options=('emptydirs')
+
+conflicts=('hostapd')
+provides=('hostapd')
+
+pkgver() {
+ cd "${srcdir}/hostap"
+ git log -1 --format='%cd.%h' --date=short | tr -d -
+}
+
+build() {
+ cd "${srcdir}/hostap/hostapd"
+ sed -i 's:/etc/hostapd:/etc/hostapd/hostapd:' hostapd.conf
+ sed -i '/CONFIG_LIBNL32=y/s/^#//' defconfig
+ cp defconfig .config
+ make
+}
+
+package() {
+ cd "${srcdir}/hostap/hostapd"
+
+ install -d "${pkgdir}"/usr/bin
+ install -t "${pkgdir}"/usr/bin hostapd hostapd_cli
+
+ install -d "${pkgdir}"/usr/share/doc/hostapd
+ install -t "${pkgdir}"/usr/share/doc/hostapd -m644 hostapd.[a-z]* wired.conf hlr_auc_gw.milenage_db
+
+ install -d "${pkgdir}"/etc/hostapd
+ install -Dm644 hostapd.8 "${pkgdir}"/usr/share/man/man8/hostapd.8
+ install -Dm644 hostapd_cli.1 "${pkgdir}"/usr/share/man/man1/hostapd_cli.1
+ install -Dm644 ../COPYING "${pkgdir}"/usr/share/licenses/hostapd/COPYING
+ install -Dm644 ../../service "${pkgdir}"/usr/lib/systemd/system/hostapd.service
+}
diff --git a/service b/service
new file mode 100644
index 000000000000..40bda06c78fc
--- /dev/null
+++ b/service
@@ -0,0 +1,10 @@
+[Unit]
+Description=Hostapd IEEE 802.11 AP, IEEE 802.1X/WPA/WPA2/EAP/RADIUS Authenticator
+After=network.target
+
+[Service]
+ExecStart=/usr/bin/hostapd /etc/hostapd/hostapd.conf
+ExecReload=/bin/kill -HUP $MAINPID
+
+[Install]
+WantedBy=multi-user.target