summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorViktor Drobot2021-01-27 20:05:41 +0300
committerViktor Drobot2021-01-27 20:05:41 +0300
commit7075ccb5dccb24f20dada94337c59df0638886c7 (patch)
tree091e04f42aae855f89336bfdc01a0a1bc3f81947
parent42a82e193e29e69f9f4b40e0716dafcc770c2ba3 (diff)
downloadaur-7075ccb5dccb24f20dada94337c59df0638886c7.tar.gz
Fix CVE-2020-12695; match pkgrel with main repo
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD14
2 files changed, 19 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9f04e8ae8bec..1b694878d48d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = hostapd-noscan
pkgdesc = IEEE 802.11 AP, IEEE 802.1X/WPA/WPA2/EAP/RADIUS Authenticator (with "noscan" patch)
pkgver = 2.9
- pkgrel = 2
+ pkgrel = 4
url = https://w1.fi/hostapd/
arch = x86_64
arch = i686
@@ -23,10 +23,16 @@ pkgbase = hostapd-noscan
backup = etc/hostapd/hostapd.vlan
backup = etc/hostapd/hostapd.wpa_psk
source = https://w1.fi/releases/hostapd-2.9.tar.gz
+ source = https://w1.fi/security/2020-1/0001-WPS-UPnP-Do-not-allow-event-subscriptions-with-URLs-.patch
+ source = https://w1.fi/security/2020-1/0002-WPS-UPnP-Fix-event-message-generation-using-a-long-U.patch
+ source = https://w1.fi/security/2020-1/0003-WPS-UPnP-Handle-HTTP-initiation-failures-for-events-.patch
source = config
source = hostapd.service
source = hostapd-noscan.patch
sha256sums = 881d7d6a90b2428479288d64233151448f8990ab4958e0ecaca7eeb3c9db2bd7
+ sha256sums = 2d9a5b9d616f1b4aa4a22b967cee866e2f69b798b0b46803a7928c8559842bd7
+ sha256sums = 49feb35a5276279b465f6836d6fa2c6b34d94dc979e8b840d1918865c04260de
+ sha256sums = a8212a2d89a5bab2824d22b6047e7740553df163114fcec94832bfa9c5c5d78a
sha256sums = 87445203a518864e704b85fa970d90940e9a5d9b401ceb802d11caab6c07a495
sha256sums = 989bc6855f44c0b360e3d4cd4a146c35b7c12f8a0ced627b4b033f58edcade8e
sha256sums = f2a57f118d5884bdc5eaba3828545742775e763eade4837668f8cd3dec8bb812
diff --git a/PKGBUILD b/PKGBUILD
index 6bc1cbe461e4..415f0fcc6397 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=hostapd-noscan
_pkgname="hostapd"
pkgver=2.9
-pkgrel=2
+pkgrel=4
pkgdesc="IEEE 802.11 AP, IEEE 802.1X/WPA/WPA2/EAP/RADIUS Authenticator (with \"noscan\" patch)"
arch=('x86_64' 'i686' 'armv6h' 'armv7h' 'aarch64')
url="https://w1.fi/hostapd/"
@@ -15,10 +15,16 @@ conflicts=('hostapd')
provides=('hostapd')
backup=("etc/${_pkgname}/${_pkgname}."{accept,conf,deny,eap_user,radius_clients,vlan,wpa_psk})
source=("https://w1.fi/releases/$_pkgname-$pkgver.tar.gz"
+ "https://w1.fi/security/2020-1/0001-WPS-UPnP-Do-not-allow-event-subscriptions-with-URLs-.patch"
+ "https://w1.fi/security/2020-1/0002-WPS-UPnP-Fix-event-message-generation-using-a-long-U.patch"
+ "https://w1.fi/security/2020-1/0003-WPS-UPnP-Handle-HTTP-initiation-failures-for-events-.patch"
"config"
"hostapd.service"
"hostapd-noscan.patch")
sha256sums=('881d7d6a90b2428479288d64233151448f8990ab4958e0ecaca7eeb3c9db2bd7'
+ '2d9a5b9d616f1b4aa4a22b967cee866e2f69b798b0b46803a7928c8559842bd7'
+ '49feb35a5276279b465f6836d6fa2c6b34d94dc979e8b840d1918865c04260de'
+ 'a8212a2d89a5bab2824d22b6047e7740553df163114fcec94832bfa9c5c5d78a'
'87445203a518864e704b85fa970d90940e9a5d9b401ceb802d11caab6c07a495'
'989bc6855f44c0b360e3d4cd4a146c35b7c12f8a0ced627b4b033f58edcade8e'
'f2a57f118d5884bdc5eaba3828545742775e763eade4837668f8cd3dec8bb812')
@@ -45,8 +51,12 @@ prepare() {
ln -sv "${srcdir}/config" "${_pkgname}/.config"
# apply "noscan" patch
- msg2 "Applying \"noscan\" patch"
patch -p1 -i "$srcdir/hostapd-noscan.patch"
+
+ # fix CVE-2020-12695
+ patch -Np1 -i "$srcdir/0001-WPS-UPnP-Do-not-allow-event-subscriptions-with-URLs-.patch"
+ patch -Np1 -i "$srcdir/0002-WPS-UPnP-Fix-event-message-generation-using-a-long-U.patch"
+ patch -Np1 -i "$srcdir/0003-WPS-UPnP-Handle-HTTP-initiation-failures-for-events-.patch"
}
build() {