summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBarbUk2020-04-16 09:30:08 +0400
committerBarbUk2020-04-16 09:30:08 +0400
commit9abce1cd980369f09b094c1167aa2af2719ae1c6 (patch)
tree7c77c52b99f04f8decd37f21fd43d2688ffe129d
parent70a451b5e0e54c7a5c23473c8c6e3c1f48e2736d (diff)
downloadaur-9abce1cd980369f09b094c1167aa2af2719ae1c6.tar.gz
Add -s and -w ldflags
-rw-r--r--PKGBUILD2
1 files changed, 1 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3486553bab7b..528f4328c10b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,7 +16,7 @@ build() {
cd $pkgname-$pkgver
go build \
-trimpath \
- -ldflags "-X github.com/guumaster/hostctl/cmd.version=$pkgver -extldflags $LDFLAGS" \
+ -ldflags "-X github.com/guumaster/hostctl/cmd.version=$pkgver -s -w -extldflags $LDFLAGS" \
-o $pkgname cmd/hostctl/main.go
}