summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBarbUk2020-04-14 14:41:57 +0400
committerBarbUk2020-04-14 14:41:57 +0400
commit404b2b471c295cfcf94b8a370161de2f31f3f4cd (patch)
tree37ab8f91956bd0a8233582e1d65e02fe0b6d4750
downloadaur-404b2b471c295cfcf94b8a370161de2f31f3f4cd.tar.gz
Create package hostctl-bin
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD18
2 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f2fed86984a1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = hostctl-bin
+ pkgdesc = Command-line tool to manage your hosts file
+ pkgver = 1.0.2
+ pkgrel = 1
+ url = https://github.com/guumaster/hostctl
+ arch = x86_64
+ license = MIT
+ provides = hostctl
+ conflicts = hostctl
+ source = https://github.com/guumaster/hostctl/releases/download/v1.0.2/hostctl_1.0.2_linux_64-bit.tar.gz
+ sha256sums = 3faacdb6074ec0b1418502aa47146b79e29719bdacda255917e507d325f279d6
+
+pkgname = hostctl-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b3d04f1b42d9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Julien Virey <julien.virey@gmail.com>
+
+pkgname=hostctl-bin
+pkgver=1.0.2
+pkgrel=1
+pkgdesc='Command-line tool to manage your hosts file'
+arch=('x86_64')
+url='https://github.com/guumaster/hostctl'
+license=('MIT')
+provides=("${pkgname%-bin}")
+conflicts=("${pkgname%-bin}")
+source=("$url/releases/download/v$pkgver/${pkgname%-bin}_${pkgver}_linux_64-bit.tar.gz")
+sha256sums=('3faacdb6074ec0b1418502aa47146b79e29719bdacda255917e507d325f279d6')
+
+package() {
+ install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname%-bin}/"
+ install -Dm755 "${pkgname%-bin}" "$pkgdir/usr/bin/${pkgname%-bin}"
+}