summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgraysky2015-06-08 17:59:54 -0400
committergraysky2015-06-08 17:59:54 -0400
commitb69069e1cc05b0ee0ec472565ad487e7dc7d8043 (patch)
tree683fc10cea862696977f100ffa2bc9e695fd8475
downloadaur-b69069e1cc05b0ee0ec472565ad487e7dc7d8043.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD25
-rw-r--r--readme.install20
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..93c9bb0bd34b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = hosts-update
+ pkgdesc = Injects the mvps blocklist to /etc/hosts to prevent thousands of parasites, hijackers and unwanted adware/spyware/privacy websites from working.
+ pkgver = 1.35
+ pkgrel = 1
+ url = https://github.com/graysky2/hosts-update
+ install = readme.install
+ arch = any
+ license = GPL
+ depends = curl
+ conflicts = hosts_update
+ replaces = hosts_update
+ backup = etc/hosts.local
+ source = http://repo-ck.com/source/hosts-update/hosts-update-1.35.tar.xz
+ sha256sums = 5e5e8e7b2e5981fe3ad6b9c94f4a0fd9fd95de8ae6b8b8e7c1b136338c383162
+
+pkgname = hosts-update
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b715a5511365
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Contributor: graysky <graysky AT archlinux dot us>
+pkgname=hosts-update
+pkgver=1.35
+pkgrel=1
+pkgdesc='Injects the mvps blocklist to /etc/hosts to prevent thousands of parasites, hijackers and unwanted adware/spyware/privacy websites from working.'
+arch=('any')
+depends=('curl')
+license=('GPL')
+url=("https://github.com/graysky2/hosts-update")
+source=("http://repo-ck.com/source/$pkgname/$pkgname-$pkgver.tar.xz")
+replaces=('hosts_update')
+conflicts=('hosts_update')
+backup=('etc/hosts.local')
+sha256sums=('5e5e8e7b2e5981fe3ad6b9c94f4a0fd9fd95de8ae6b8b8e7c1b136338c383162')
+install=readme.install
+
+build() {
+ cd "$pkgname-$pkgver"
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+}
diff --git a/readme.install b/readme.install
new file mode 100644
index 000000000000..217e5294a8f9
--- /dev/null
+++ b/readme.install
@@ -0,0 +1,20 @@
+post_install() {
+ echo '--------------------------------------------------------------------------'
+ echo ' SETUP INSTRUCTIONS'
+ echo
+ echo ' 1) Edit /etc/hosts.local to match the hostname of your system and adjust'
+ echo ' the domainname as needed. Also add any hosts that you wish to keep'
+ echo ' i.e. other PCs on your network.'
+ echo
+ echo ' 2) Run the script as root which will append /etc/hosts.local to the mvps'
+ echo ' blocklist and apply some post processing writing the final file'
+ echo ' to /etc/hosts automatically.'
+ echo
+ echo ' 3) (Optional) Add a cronjob under root crontab at some interval to keep'
+ echo ' your /etc/hosts fresh.'
+ echo
+ echo ' If you are updating from the package named hosts_update you should'
+ echo ' change any crontab entries to use the new name of the script which'
+ echo ' is hosts-update (note the hyphen not an underscore.)'
+ echo '--------------------------------------------------------------------------'
+}