summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormaz-12015-10-14 20:56:22 +0800
committermaz-12015-10-14 20:56:22 +0800
commit5dcfd56a727472ea94e4a9a6dccbe14a5708072c (patch)
tree302c6c8e7cf84ded9b497dad83ee6485cbe87446
downloadaur-5dcfd56a727472ea94e4a9a6dccbe14a5708072c.tar.gz
init
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD30
-rwxr-xr-xhoststool.desktop20
-rw-r--r--hoststool.pngbin0 -> 65679 bytes
4 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c0653a08836d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = hoststool
+ pkgdesc = Original library for SoundFont compression.
+ pkgver = 1.9.8
+ pkgrel = 1
+ url = https://code.google.com/p/huhamhire-hosts/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = python2-pyqt4
+ depends = gksu
+ source = https://huhamhire-hosts.googlecode.com/git-history/gh-pages/release/HostsTool-x11-gpl-1.9.8-SE.tar.gz
+ source = hoststool.png
+ source = hoststool.desktop
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = hoststool
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a27e07388941
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: maz-1 <ohmygod19993 at gmail dot com>
+pkgname=hoststool
+pkgver=1.9.8
+pkgrel=1
+pkgdesc="Original library for SoundFont compression."
+arch=(i686 x86_64)
+url="https://code.google.com/p/huhamhire-hosts/"
+license=('GPL')
+depends=('python2-pyqt4' 'gksu')
+source=("https://huhamhire-hosts.googlecode.com/git-history/gh-pages/release/HostsTool-x11-gpl-${pkgver}-SE.tar.gz" "hoststool.png" "hoststool.desktop")
+md5sums=('982eb0fedc5c3b076326eaf06fc87c23'
+ 'b79a5fd9df05c3e384f37b3f68cef92d'
+ 'bea986c720b09e18095d022c86b4734d')
+
+prepare() {
+ cd "$srcdir/HostsTool-x11-gpl-${pkgver}-SE"
+ find -name '*.py' | xargs sed -i 's|#!/usr/bin/python$|#!/usr/bin/env python2|'
+}
+
+package() {
+ install -dm 755 "$pkgdir/usr/"{share,bin}
+ cp -r "$srcdir/HostsTool-x11-gpl-${pkgver}-SE" "$pkgdir/usr/share/hoststool"
+ echo '#!/bin/sh' > "$pkgdir/usr/bin/hoststool"
+ echo 'cd /usr/share/hoststool' >> "$pkgdir/usr/bin/hoststool"
+ echo 'exec python2 hoststool.py' >> "$pkgdir/usr/bin/hoststool"
+ chmod +x "$pkgdir/usr/bin/hoststool"
+ install -Dm 644 "$srcdir/hoststool.png" "${pkgdir}/usr/share/icons/hoststool.png"
+ install -Dm 755 "$srcdir/hoststool.desktop" "${pkgdir}/usr/share/applications/hoststool.desktop"
+}
+
diff --git a/hoststool.desktop b/hoststool.desktop
new file mode 100755
index 000000000000..90d8bfe063ec
--- /dev/null
+++ b/hoststool.desktop
@@ -0,0 +1,20 @@
+[Desktop Entry]
+Categories=Utility;
+Comment[zh_CN]=Hosts编辑器
+Comment=Hosts Editor
+Exec=gksu hoststool
+GenericName[zh_CN]=
+GenericName=
+Icon=hoststool.png
+MimeType=
+Name[zh_CN]=Hosts设置程序
+Name=Hosts Setup Utility
+Path=
+StartupNotify=true
+Terminal=false
+TerminalOptions=
+Type=Application
+X-DBUS-ServiceName=
+X-DBUS-StartupType=
+X-KDE-SubstituteUID=false
+X-KDE-Username=
diff --git a/hoststool.png b/hoststool.png
new file mode 100644
index 000000000000..53e479e6a906
--- /dev/null
+++ b/hoststool.png
Binary files differ