summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAleksey Filippov2018-03-01 17:27:39 +0000
committerAleksey Filippov2018-03-01 17:29:26 +0000
commiteb75ac3249bdf49226c6371a11701bc68560d523 (patch)
tree78a7524a25e475934f0e260694987a9a445d2d10
parent9f44b54d16c2437fb74cc3420c49ce7b6bc8c556 (diff)
parent82442874db04f804ebdbc59dc5b9cdb7378fd355 (diff)
downloadaur-eb75ac3249bdf49226c6371a11701bc68560d523.tar.gz
Replace old package
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD63
2 files changed, 64 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 93a2c8d51273..73b5e3eb2e8d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,21 @@
# Generated by mksrcinfo v8
-# Wed Nov 2 14:53:58 UTC 2016
+# Thu Mar 1 17:29:26 UTC 2018
pkgbase = hotdoc
- pkgdesc = The tastiest API documentation system.
- pkgver = 0.8.1
+ pkgdesc = HotDoc: the tastiest API documentation system
+ pkgver = 0.8.92
pkgrel = 1
url = https://github.com/hotdoc/hotdoc
- arch = i686
- arch = x86_64
- license = LGPLv2
- depends = python2
- depends = python2-sqlalchemy
- depends = python2-schema
- depends = python2-toposort
- depends = python2-wheezy
- depends = python2-pygraphviz
- source = git+https://github.com/hotdoc/hotdoc.git#tag=0.8.1
- md5sums = SKIP
+ arch = any
+ license = LGPL2
+ depends = python
+ depends = python-sqlalchemy
+ depends = python-yaml
+ depends = python-schema
+ depends = python-toposort
+ depends = python-lxml
+ depends = python-wheezy
+ source = git+https://github.com/hotdoc/hotdoc.git#tag=0.8.92
+ sha256sums = SKIP
pkgname = hotdoc
diff --git a/PKGBUILD b/PKGBUILD
index 51dc7dab8dab..e8d9d54354ff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,58 @@
-# Maintainer: Lubosz Sarnecki <lubosz@gmail.com>
+# Copyright 2018 Google LLC
+
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+
+# http://www.apache.org/licenses/LICENSE-2.0
+
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+# Maintainer: Aleksey Filippov <sarum9in@gmail.com>
+# Contributor: Lubosz Sarnecki <lubosz@gmail.com>
pkgname=hotdoc
-pkgver=0.8.1
+pkgver=0.8.92
pkgrel=1
-pkgdesc="The tastiest API documentation system."
-arch=('i686' 'x86_64')
+epoch=
+pkgdesc="HotDoc: the tastiest API documentation system"
+arch=('any')
url="https://github.com/hotdoc/hotdoc"
-license=('LGPLv2')
-depends=('python2' 'python2-sqlalchemy' 'python2-schema' 'python2-toposort' 'python2-wheezy' 'python2-pygraphviz')
-source=("git+https://github.com/hotdoc/hotdoc.git#tag=$pkgver")
-md5sums=('SKIP')
+license=('LGPL2')
+groups=()
+depends=(
+ 'python'
+ 'python-sqlalchemy'
+ 'python-yaml'
+ 'python-schema'
+ 'python-toposort'
+ 'python-lxml'
+ 'python-wheezy'
+)
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("git+https://github.com/${pkgname}/${pkgname}.git#tag=${pkgver}")
+noextract=()
+sha256sums=('SKIP')
+validpgpkeys=()
build() {
- cd hotdoc
- python2 setup.py build
+ cd "$pkgname"
+ python setup.py build
}
-
+
package() {
- cd hotdoc
- python2 setup.py install --root="$pkgdir" --optimize=1
+ cd "$pkgname"
+ python setup.py install --root="$pkgdir/" --optimize=1
}