summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSergey Khorev2015-06-28 20:55:53 +0300
committerSergey Khorev2015-06-28 20:55:53 +0300
commit8c2a4f1aea52660619b94378433e13e497eb06d8 (patch)
treea53da043b3ed25752d62b085bd90f44c9de0cf12
downloadaur-hothasktags.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD26
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f328eaabdeb3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = hothasktags
+ pkgdesc = Generates ctags for Haskell, incorporating import lists and qualified imports
+ pkgver = 0.3.1
+ pkgrel = 1
+ url = http://hackage.haskell.org/package/hothasktags
+ arch = i686
+ arch = x86_64
+ license = custom:BSD3
+ makedepends = ghc
+ makedepends = haskell-containers
+ makedepends = haskell-cpphs
+ makedepends = haskell-filepath
+ makedepends = haskell-haskell-src-exts
+ depends = gmp
+ options = strip
+ source = http://hackage.haskell.org/packages/archive/hothasktags/0.3.1/hothasktags-0.3.1.tar.gz
+ md5sums = e4cde70444b03fc8e69cd4d326680351
+
+pkgname = hothasktags
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b57d21b73e96
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: serkho <sergey.khorev@gmail.com>
+_hkgname=hothasktags
+pkgname=hothasktags
+pkgver=0.3.1
+pkgrel=1
+pkgdesc="Generates ctags for Haskell, incorporating import lists and qualified imports"
+url="http://hackage.haskell.org/package/${_hkgname}"
+license=('custom:BSD3')
+arch=('i686' 'x86_64')
+makedepends=('ghc' 'haskell-containers' 'haskell-cpphs' 'haskell-filepath' 'haskell-haskell-src-exts')
+depends=('gmp')
+options=('strip')
+source=(http://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz)
+md5sums=('e4cde70444b03fc8e69cd4d326680351')
+build() {
+ cd ${srcdir}/${_hkgname}-${pkgver}
+ sed -i hothasktags.cabal -e 's/^\(\s\+cpphs\).*/\1/'
+ runhaskell Setup configure --prefix=/usr --docdir=/usr/share/doc/${pkgname} -O
+ runhaskell Setup build
+}
+package() {
+ cd ${srcdir}/${_hkgname}-${pkgver}
+ runhaskell Setup copy --destdir=${pkgdir}
+ install -D -m644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+ rm -f ${pkgdir}/usr/share/doc/${pkgname}/LICENSE
+}