summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJ0k3r2014-02-21 20:07:31 +0100
committerJ0k3r2014-02-21 20:07:31 +0100
commit5a17ec8d5b698e83706ac86139da6bd4ca9891e5 (patch)
treeff244130e0b4136ac9c4e345c761733893e01b6f
parente71e01850231997aae9572f5b5ded4a07c50d536 (diff)
downloadaur-5a17ec8d5b698e83706ac86139da6bd4ca9891e5.tar.gz
AUR4 split: Updated hotlinemiami
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD51
-rw-r--r--hotlinemiami.changelog7
3 files changed, 47 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c660a04d6e68..dd96acdafc54 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,10 @@
pkgbase = hotlinemiami
pkgdesc = A 2D top-down action video game
- pkgver = 1.0.9a
- pkgrel = 2
+ pkgver = 1392944501
+ pkgrel = 1
+ epoch = 1
url = http://hotlinemiami.com/
+ changelog = hotlinemiami.changelog
arch = i686
arch = x86_64
groups = games
@@ -12,16 +14,18 @@ pkgbase = hotlinemiami
depends = nvidia-cg-toolkit
depends = glu
depends = fontconfig
- depends = lib32-xrandr
depends = libxrandr
- depends = qt5-base
- noextract = hotlinemiami_v1.0.9a-Linux_28-05-2013.tar.gz
- source = hib://hotlinemiami_v1.0.9a-Linux_28-05-2013.tar.gz
+ depends = libxi
+ noextract = HotlineMiami_linux_1392944501.tar.gz
+ options = strip
+ source = hib://HotlineMiami_linux_1392944501.tar.gz
source = hotlinemiami.desktop
source = hotlinemiami.png
- sha256sums = 070300558ba52f75455d1645bba6dd956f460ada0d3839f8b3c3ac712ba957da
+ source = hotlinemiami.changelog
+ sha256sums = 338268eecbd63ab5cf168d85ef6c7b36f2a6999adb359222b5372651b08ba805
sha256sums = ca65c11bc9e06f438b2da2bb44c40424537e60b704656a155f672b16fde5f8de
sha256sums = 01432c725bd258761e67fe1db94531465ba0480e250724cf6b939669e13b0e8a
+ sha256sums = SKIP
pkgname = hotlinemiami
diff --git a/PKGBUILD b/PKGBUILD
index b881a346e5cc..19d086484cc0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,36 @@
# Maintainer: J0k3r <moebius282 at gmail dot com>
pkgname=hotlinemiami
-pkgver=1.0.9a
-pkgrel=2
+pkgver=1392944501
+pkgrel=1
+epoch=1
pkgdesc="A 2D top-down action video game"
url="http://hotlinemiami.com/"
license=('unknown')
# © Dennaton Interactive Design of the Future ™
arch=('i686' 'x86_64')
groups=("games")
+_purgelibs=('libopenal.so.1' 'libCgGL.so' 'libCg.so')
+# It appears like qt5 is no longer needed.
+_purgelibs+=('libQt5Core.so.5' 'libQt5Gui.so.5' 'libQt5Widgets.so.5')
+# If the program doesn't run, comment the line above. /\
if [ "$CARCH" = "x86_64" ]; then
- depends=('lib32-openal' 'lib32-libvorbis' 'lib32-nvidia-cg-toolkit' 'lib32-glu' 'lib32-fontconfig' 'lib32-libxrandr')
+ depends=('lib32-openal' 'lib32-libvorbis' 'lib32-nvidia-cg-toolkit' 'lib32-glu' 'lib32-fontconfig' 'lib32-libxrandr' 'lib32-libxi')
else
- depends=('openal' 'libvorbis' 'nvidia-cg-toolkit' 'glu' 'fontconfig' 'lib32-xrandr' 'libxrandr' 'qt5-base' )
+ depends=('openal' 'libvorbis' 'nvidia-cg-toolkit' 'glu' 'fontconfig' 'libxrandr' 'libxi')
fi
-_archivename="${pkgname}_v${pkgver}-Linux_28-05-2013"
+changelog="${pkgname}.changelog"
+_archivename="HotlineMiami_linux_${pkgver}"
source=("hib://${_archivename}.tar.gz"
"${pkgname}.desktop"
- "${pkgname}.png")
-sha256sums=('070300558ba52f75455d1645bba6dd956f460ada0d3839f8b3c3ac712ba957da'
+ "${pkgname}.png"
+ "${pkgname}.changelog")
+sha256sums=('338268eecbd63ab5cf168d85ef6c7b36f2a6999adb359222b5372651b08ba805'
'ca65c11bc9e06f438b2da2bb44c40424537e60b704656a155f672b16fde5f8de'
- '01432c725bd258761e67fe1db94531465ba0480e250724cf6b939669e13b0e8a')
+ '01432c725bd258761e67fe1db94531465ba0480e250724cf6b939669e13b0e8a'
+ 'SKIP')
noextract=("${source[0]:6}")
+options=('strip')
PKGEXT=".pkg.tar"
@@ -42,30 +51,28 @@ package()
{
install -d "${pkgdir}/opt/${pkgname}/"
-# Otherwise it extract the files loosely in $srcdir
+# Otherwise it extract the files loosely in ${srcdir}/
tar -xzf "${srcdir}/${_archivename}.tar.gz" -C "${pkgdir}/opt/${pkgname}/"
# We don't need these, as we use the shared system libraries
-# We can't go this simple way on x86_64 currently, as arch doesn't provide lib32-qt5 :(
- if [ "$CARCH" = "x86_64" ]; then
- _purgelibs=('libopenal.so.1' 'libCgGL.so' 'libCg.so')
- for i in "${_purgelibs[@]}"; do
- rm "${pkgdir}/opt/${pkgname}/lib/${i}"
- done
- chown root:root "${pkgdir}/opt/${pkgname}/lib/"
- else
- rm -r "${pkgdir}/opt/${pkgname}/lib/"
- fi
+ rm -r "${pkgdir}/opt/${pkgname}/lib/.svn/"
- find "${pkgdir}/opt/${pkgname}/" -type f -exec chown root:root "{}" \;
+ for i in "${_purgelibs[@]}"; do
+ rm "${pkgdir}/opt/${pkgname}/lib/${i}"
+ done
+ rmdir "${pkgdir}/opt/${pkgname}/lib/" &> /dev/null || true
+
+# The default owner/group is 500. I don't know if this is necessarry, but makepkg doesn't seem to set the owner/group of all files to root by default.
+ chown -R root:root "${pkgdir}/opt/${pkgname}/"*
install -D -m644 "${srcdir}/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+
# I extracted this from the windows executable; couldn't find one anywhere else
install -D -m644 "${srcdir}/${pkgname}.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+# We need this as the program expect to be launched from the same directory it resides in
install -d "${pkgdir}/usr/bin/"
-# We need this as the program expect to be launched from the same directory it resides in
cat > "${pkgdir}/usr/bin/${pkgname}" <<-EOF
#!/bin/bash
@@ -74,4 +81,4 @@ package()
EOF
chmod 0755 "${pkgdir}/usr/bin/${pkgname}"
-} \ No newline at end of file
+}
diff --git a/hotlinemiami.changelog b/hotlinemiami.changelog
new file mode 100644
index 000000000000..4ce75873c179
--- /dev/null
+++ b/hotlinemiami.changelog
@@ -0,0 +1,7 @@
+2013-02-21 | J0k3r <moebius282@gmail.com>
+
+ * hotlinemiami-1392944501-1:
+ - Updated to latest release ( HotlineMiami_linux_1392944501.tar.gz )
+ - Restructured the PKGBUILD a bit
+ - Removed the qt5 dependency
+ - Added changelog