summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Lindner2017-09-30 21:48:34 +0800
committerFlorian Lindner2017-09-30 21:48:34 +0800
commit005b7d5cd3d0b8112e137d9866372777ff1ed98b (patch)
tree39f568a7864890d5685bffa2cb75db18dc3345aa
downloadaur-005b7d5cd3d0b8112e137d9866372777ff1ed98b.tar.gz
Initial commit
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD27
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f8ba7a5e070b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+# Generated by mksrcinfo v8
+# Sat Sep 30 13:47:32 UTC 2017
+pkgbase = hotspot
+ pkgdesc = The Linux perf GUI for performance analysis
+ pkgver = 1.1.0
+ pkgrel = 1
+ url = https://github.com/KDAB/hotspot
+ arch = any
+ license = GPL2
+ makedepends = cmake>=3.1.0
+ makedepends = extra-cmake-modules
+ depends = qt5-base>=5.6.0
+ depends = libelf
+ depends = elfutils
+ depends = threadweaver
+ depends = ki18n
+ depends = kconfig
+ depends = kio
+ depends = kitemviews
+ depends = kcoreaddons
+ depends = kitemmodels
+ depends = kconfigwidgets
+ depends = solid
+ provides = hotspot
+ conflicts = hotspot-git
+ source = https://github.com/KDAB/hotspot/releases/download/v1.1.0/hotspot-v1.1.0.tar.gz
+ sha1sums = 3cef6822da0f29fb5f37b272f3d4154217628214
+
+pkgname = hotspot
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..62a780107f56
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Florian Lindner <florian.lindner@xgm.de>
+
+pkgname=hotspot
+pkgver=1.1.0
+pkgrel=1
+pkgdesc="The Linux perf GUI for performance analysis"
+arch=('any')
+url="https://github.com/KDAB/hotspot"
+license=('GPL2')
+depends=('qt5-base>=5.6.0' 'libelf' 'elfutils' 'threadweaver' 'ki18n' 'kconfig' 'kio' 'kitemviews' 'kcoreaddons' 'kitemmodels' 'kconfigwidgets' 'solid')
+makedepends=('cmake>=3.1.0' 'extra-cmake-modules')
+provides=("${pkgname}")
+conflicts=("${pkgname}-git")
+source=("https://github.com/KDAB/hotspot/releases/download/v${pkgver}/hotspot-v${pkgver}.tar.gz")
+sha1sums=('3cef6822da0f29fb5f37b272f3d4154217628214')
+
+build() {
+ cd "${pkgname}-v${pkgver}"
+ cmake . -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd "${pkgname}-v${pkgver}"
+ make DESTDIR="${pkgdir}/" install
+ mv "$pkgdir/usr/lib64" "$pkgdir/usr/lib"
+}