summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarco Rubin2024-03-05 20:46:27 +0100
committerMarco Rubin2024-03-05 20:46:27 +0100
commit2966e4f01cdcb1bb9bf930eb5990c93ff162e7a7 (patch)
tree8d59ffb998b5665725bc0aa5f112a584b447709f
parent0f0be02a20ef4b58d7f9bb5528d7c10acfbfaf48 (diff)
downloadaur-2966e4f01cdcb1bb9bf930eb5990c93ff162e7a7.tar.gz
get git submodules from source array
-rwxr-xr-x.SRCINFO6
-rwxr-xr-xPKGBUILD13
2 files changed, 14 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3242bba2f1e5..5a661a9e1091 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = hotspot
pkgdesc = The Linux perf GUI for performance analysis
pkgver = 20240304
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/KDAB/hotspot
arch = x86_64
license = GPL-2.0-only
@@ -26,6 +26,10 @@ pkgbase = hotspot
depends = solid5
depends = threadweaver5
source = git+https://github.com/KDAB/hotspot#commit=6f9f958c4ff68b3c94ccca0fa3c2d86c46c9185f
+ source = git+https://github.com/KDAB/perfparser.git
+ source = git+https://github.com/koenpoppe/PrefixTickLabels
+ b2sums = SKIP
+ b2sums = SKIP
b2sums = SKIP
pkgname = hotspot
diff --git a/PKGBUILD b/PKGBUILD
index c36573c7c580..055bce1db391 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=hotspot
pkgver=20240304
-pkgrel=1
+pkgrel=2
pkgdesc="The Linux perf GUI for performance analysis"
arch=('x86_64')
url="https://github.com/KDAB/hotspot"
@@ -27,12 +27,17 @@ depends=(
'threadweaver5'
)
makedepends=('cmake>=3.16.0' 'desktop-file-utils' 'extra-cmake-modules' 'git')
-source=("git+$url#commit=6f9f958c4ff68b3c94ccca0fa3c2d86c46c9185f")
-b2sums=('SKIP')
+source=("git+$url#commit=6f9f958c4ff68b3c94ccca0fa3c2d86c46c9185f"
+ "git+https://github.com/KDAB/perfparser.git"
+ "git+https://github.com/koenpoppe/PrefixTickLabels")
+b2sums=('SKIP' 'SKIP' 'SKIP')
prepare() {
cd $pkgname
- git submodule update --init --recursive
+ git submodule init
+ git config submodule.3rdparty/perfparser.url "$srcdir/perfparser"
+ git config submodule.3rdparty/PrefixTickLabels.url "$srcdir/PrefixTickLabels"
+ git -c protocol.file.allow=always submodule update
}
build() {