summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Lindner2020-11-20 14:01:59 +0100
committerFlorian Lindner2020-11-20 14:01:59 +0100
commit6ecba21acb85bccd5c3fd64a6ead4b105eaa23ba (patch)
tree2cb8e3b673ac79bb897e20ace8e0f9aa6ba80973
parent13de660cbc5864bbb69ccaf892c3141a29f5983c (diff)
downloadaur-6ecba21acb85bccd5c3fd64a6ead4b105eaa23ba.tar.gz
Install .desktop file from upstream.
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD3
2 files changed, 3 insertions, 1 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c863bfaacca9..23d10589107b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,6 +7,7 @@ pkgbase = hotspot
license = GPL2
makedepends = cmake>=3.1.0
makedepends = extra-cmake-modules
+ makedepends = desktop-file-utils
depends = qt5-base>=5.6.0
depends = libelf
depends = elfutils
diff --git a/PKGBUILD b/PKGBUILD
index 8fb9ee75c00b..fc7a4e84e051 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ arch=('any')
url="https://github.com/KDAB/hotspot"
license=('GPL2')
depends=('qt5-base>=5.6.0' 'libelf' 'elfutils' 'threadweaver' 'ki18n' 'kconfig' 'kio' 'kitemviews' 'kcoreaddons' 'kitemmodels' 'kconfigwidgets' 'solid')
-makedepends=('cmake>=3.1.0' 'extra-cmake-modules')
+makedepends=('cmake>=3.1.0' 'extra-cmake-modules' 'desktop-file-utils')
provides=("${pkgname}")
conflicts=("${pkgname}-git")
source=("https://github.com/KDAB/hotspot/releases/download/v${pkgver}/hotspot-v${pkgver}.tar.gz")
@@ -23,4 +23,5 @@ build() {
package() {
cd "${pkgname}-v${pkgver}"
make DESTDIR="${pkgdir}/" install
+ desktop-file-install hotspot.desktop --dir="${pkgdir}/usr/share/applications/"
}