summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarco Rubin2024-03-22 14:00:53 +0100
committerMarco Rubin2024-03-22 14:00:53 +0100
commitf246d50c4fec2c6dca877236b3e0fa15d5e5b30c (patch)
tree459aca2bb5c3d285a2339c8b49076496e3cc7512
parent2966e4f01cdcb1bb9bf930eb5990c93ff162e7a7 (diff)
downloadaur-f246d50c4fec2c6dca877236b3e0fa15d5e5b30c.tar.gz
20240312
-rwxr-xr-x.SRCINFO8
-rwxr-xr-xPKGBUILD16
2 files changed, 16 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5a661a9e1091..96f04563cb5e 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = hotspot
pkgdesc = The Linux perf GUI for performance analysis
- pkgver = 20240304
- pkgrel = 2
+ pkgver = 20240312
+ pkgrel = 1
url = https://github.com/KDAB/hotspot
arch = x86_64
license = GPL-2.0-only
@@ -25,10 +25,10 @@ pkgbase = hotspot
depends = rustc-demangle>=0.1.18-2
depends = solid5
depends = threadweaver5
- source = git+https://github.com/KDAB/hotspot#commit=6f9f958c4ff68b3c94ccca0fa3c2d86c46c9185f
+ source = git+https://github.com/KDAB/hotspot#commit=61c5ad91765d5916d211742949878004d725ac51
source = git+https://github.com/KDAB/perfparser.git
source = git+https://github.com/koenpoppe/PrefixTickLabels
- b2sums = SKIP
+ b2sums = 338f32fea8ab56f11211ec161f30746546400ee4066ba2d6d44a6cb95aaba16bbb85a442439ab76eb5b9eb983e5963e4e8116234649667da8d491dbb878cab08
b2sums = SKIP
b2sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 055bce1db391..54922e88e5da 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,9 @@
# Contributor: Florian Lindner <florian.lindner@xgm.de>
pkgname=hotspot
-pkgver=20240304
-pkgrel=2
+pkgver=20240312
+_commit=61c5ad91765d5916d211742949878004d725ac51
+pkgrel=1
pkgdesc="The Linux perf GUI for performance analysis"
arch=('x86_64')
url="https://github.com/KDAB/hotspot"
@@ -27,10 +28,17 @@ depends=(
'threadweaver5'
)
makedepends=('cmake>=3.16.0' 'desktop-file-utils' 'extra-cmake-modules' 'git')
-source=("git+$url#commit=6f9f958c4ff68b3c94ccca0fa3c2d86c46c9185f"
+source=("git+$url#commit=$_commit"
"git+https://github.com/KDAB/perfparser.git"
"git+https://github.com/koenpoppe/PrefixTickLabels")
-b2sums=('SKIP' 'SKIP' 'SKIP')
+b2sums=('338f32fea8ab56f11211ec161f30746546400ee4066ba2d6d44a6cb95aaba16bbb85a442439ab76eb5b9eb983e5963e4e8116234649667da8d491dbb878cab08'
+ 'SKIP'
+ 'SKIP')
+
+pkgver() {
+ cd $pkgname
+ git log -n1 --pretty='format:%cd' --date=format:'%Y%m%d' $_commit
+}
prepare() {
cd $pkgname