summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcondy2020-01-17 11:43:47 +0800
committercondy2020-01-17 11:43:47 +0800
commitb3fd6c9cab1f0eb483fea5c028544dd5ced10ca1 (patch)
tree4a1f2dcda542466e290dfb433b65bb703f14a037
downloadaur-b3fd6c9cab1f0eb483fea5c028544dd5ced10ca1.tar.gz
Initial release
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD49
2 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ff8fae7a6658
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = hotspot-appimage
+ pkgdesc = The Linux perf GUI for performance analysis.
+ pkgver = 1.2.0
+ pkgrel = 1
+ url = https://github.com/KDAB/hotspot
+ arch = x86_64
+ license = GPL
+ depends = perf
+ provides = hotspot
+ noextract = hotspot-appimage-1.2.0.AppImage
+ options = !strip
+ source_x86_64 = hotspot-appimage-1.2.0.AppImage::https://github.com/KDAB/hotspot/releases/download/v1.2.0/hotspot-v1.2.0-x86_64.AppImage
+ md5sums_x86_64 = c2054e28bff59894927d555d1d70beb9
+
+pkgname = hotspot-appimage
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2d4e7da96998
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Zhiwei Chen <condy0919@gmail.com>
+
+_pkgname=hotspot
+pkgname="${_pkgname}"-appimage
+pkgver=1.2.0
+pkgrel=1
+pkgdesc="The Linux perf GUI for performance analysis."
+arch=('x86_64')
+url="https://github.com/KDAB/hotspot"
+license=('GPL')
+depends=('perf')
+conficts=('hotspot')
+provides=('hotspot')
+options=(!strip)
+_appimage="${pkgname}-${pkgver}.AppImage"
+source_x86_64=("${_appimage}::https://github.com/KDAB/hotspot/releases/download/v${pkgver}/${_pkgname}-v${pkgver}-x86_64.AppImage"
+ )
+md5sums_x86_64=('c2054e28bff59894927d555d1d70beb9')
+noextract=("${_appimage}")
+
+prepare() {
+ chmod +x "${_appimage}"
+ ./"${_appimage}" --appimage-extract
+}
+
+build() {
+ # Fix permissions; .AppImage permissions are 700 for all directories
+ chmod -R a-x+rX squashfs-root/opt
+}
+
+package() {
+ # AppImage
+ install -Dm755 "${_appimage}" \
+ "${pkgdir}/opt/${pkgname}/${pkgname}.AppImage"
+
+ # Desktop file
+ install -Dm644 "squashfs-root/${_pkgname}.desktop" \
+ "${pkgdir}/usr/share/applications/${_pkgname}.desktop"
+
+ # Icon images
+ cp -a "squashfs-root/opt/share/icons" "${pkgdir}/usr/share/"
+
+ # Symlink executable
+ install -dm755 "${pkgdir}/usr/bin/"
+ ln -s "/opt/${pkgname}/${pkgname}.AppImage" \
+ "${pkgdir}/usr/bin/${_pkgname}"
+}
+
+# vim:set ts=2 sw=2 et: