summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDror Levin2019-08-23 00:14:10 +0300
committerDror Levin2019-08-23 00:30:43 +0300
commit2679ef3b9d385e2c450905f559e1b32d9aaa988a (patch)
tree07ffccc9141c4888888c69df45a5c8fc088b8024
downloadaur-2679ef3b9d385e2c450905f559e1b32d9aaa988a.tar.gz
0.1.0
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD29
3 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..95fae662bb97
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = houserat
+ pkgdesc = Notifies when known devices connect to the network
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/drrlvn/houserat
+ arch = x86_64
+ license = GPL3
+ makedepends = rust
+ depends = libpcap
+ backup = etc/houserat/config.toml
+ source = houserat-0.1.0.tar.gz::https://github.com/drrlvn/houserat/archive/0.1.0.tar.gz
+ sha512sums = 86673e1a7fc588e9fa941caa27d0ef183a8663191eeeb24a47fc9cfe78c1dea6ca9a39fc7170c43c43a749c8c8bb2efbbc0f1b82486d9d3b15e0d10ce6e57e5f
+
+pkgname = houserat
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..bc0bad05b5fd
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+houserat-*
+src/
+pkg/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dbd09e4e67b6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Dror Levin <spatz@psybear.com>
+
+pkgname=houserat
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Notifies when known devices connect to the network"
+arch=(x86_64)
+url="https://github.com/drrlvn/houserat"
+license=(GPL3)
+depends=(libpcap)
+makedepends=(rust)
+backup=(etc/houserat/config.toml)
+source=($pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz)
+sha512sums=('86673e1a7fc588e9fa941caa27d0ef183a8663191eeeb24a47fc9cfe78c1dea6ca9a39fc7170c43c43a749c8c8bb2efbbc0f1b82486d9d3b15e0d10ce6e57e5f')
+
+build() {
+ cd $pkgname-$pkgver
+
+ cargo build --release
+}
+
+package() {
+ cd $pkgname-$pkgver
+
+ install -Dm755 target/release/$pkgname "$pkgdir"/usr/bin/$pkgname
+ install -Dm644 config.toml.example "$pkgdir"/etc/houserat/config.toml
+ install -Dm644 $pkgname.service "$pkgdir"/usr/lib/systemd/system/$pkgname.service
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}