summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Baum2017-04-22 18:38:50 +0200
committerDavid Baum2017-04-22 18:38:50 +0200
commit83271ad7ed70ffff762f0c29f6370a101bd6da6d (patch)
treebd39e3c9ee93d2a42608d872ccccd677ea82e506
downloadaur-83271ad7ed70ffff762f0c29f6370a101bd6da6d.tar.gz
initial version
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD31
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ab5e248a4411
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = hovercraft-git
+ pkgdesc = Makes impress.js presentations from reStructuredText
+ pkgver = 211
+ pkgrel = 1
+ url = https://github.com/regebro/hovercraft
+ arch = i686
+ arch = x86_64
+ license = MIT
+ depends = python-pygments
+ depends = python-watchdog
+ depends = python-svg.path
+ depends = python-lxml
+ depends = python-docutils
+ source = git+https://github.com/regebro/hovercraft.git
+ md5sums = SKIP
+
+pkgname = hovercraft-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0fcc71317cdb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: David Baum <david.baum@naraesk.eu>
+pkgname=hovercraft-git
+pkgver=211
+pkgrel=1
+pkgdesc="Makes impress.js presentations from reStructuredText"
+arch=('i686' 'x86_64')
+url="https://github.com/regebro/hovercraft"
+license=('MIT')
+groups=()
+depends=('python-pygments' 'python-watchdog' 'python-svg.path' 'python-lxml' 'python-docutils')
+optdepends=()
+provides=()
+conflicts=('')
+replaces=()
+backup=()
+options=()
+install=()
+changelog=()
+source=('git+https://github.com/regebro/hovercraft.git')
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd hovercraft
+ git rev-list --count HEAD
+}
+
+package() {
+ cd hovercraft
+ python setup.py install --root="$pkgdir/" --prefix=/usr --optimize=1
+}